Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452182 - Miro cannot display anything with the new xul
Summary: Miro cannot display anything with the new xul
Keywords:
Status: CLOSED DUPLICATE of bug 452115
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: 9
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Thorsten Scherf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 21:30 UTC by Peter Janakiev
Modified: 2008-06-20 04:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-20 04:35:07 UTC


Attachments (Terms of Use)

Description Peter Janakiev 2008-06-19 21:30:20 UTC
Description of problem:
After the upgrade to xulrunner-1.9-1.fc9.x86_64 Miro does not display anything
in the part of the application when it is supposed to render html stuff (like
the side tree and the main page). 


Version-Release number of selected component (if applicable):

Miro-1.2.3-2.fc9.x86_64

How reproducible:
Always, even if I delete the ~/.miro directory the issue persists


Steps to Reproduce:
1.Start Miro
2.Wait for it to load the Start Page or anything in the left tree view panel
3.
  
Actual results:
Nothing is displayed where the gecko is supposed to render the html

Expected results:
normal work flow

Additional info:
No errors are indicated in the log:
 [malwk@localhost ~]$ mv .miro/ .miroBU
[malwk@localhost ~]$ miro
INFO     Starting up Miro
INFO     Version:    1.2.3
INFO     Revision:  
https://svn.participatoryculture.org/svn/dtv/tags/Miro-1.2.3/tv/resources - 6787
INFO     Builder:    mockbuild@xenbuilder1.fedora.redhat.com
INFO     Build Time: 1209388093.16
INFO     Starting event loop thread
INFO     Restoring database...
INFO     Connecting to /home/malwk/.miro/sqlitedb
TIMING   Database load slow: 0.050
INFO     Spawning global feed dtv:manualFeed
INFO     Spawning global feed dtv:singleFeed
INFO     Spawning global feed dtv:search
INFO     Spawning global feed dtv:searchDownloads
INFO     wbg: setting autodownload stuff initially to off
INFO     Spawning global feed dtv:directoryfeed
INFO     wbg: setting autodownload stuff initially to off
INFO     Creating channel tab order
INFO     Creating playlist tab order
INFO     Spawning Miro Guide...
INFO     Spawning auto downloader...
TIMING   Icon clear: 0.001
INFO     Starting movie data updates
INFO     Adding default feeds
INFO     Displaying main frame...
/home/malwk/.themes/All/gtk-2.0/scrolls/scrollbar.rc:83: Unable to locate image
file in pixmap_path: "scrollbar_horizontal.png"
/home/malwk/.themes/All/gtk-2.0/scrolls/scrollbar.rc:87: Background image
options specified without filename
INFO     *** Launching Downloader Daemon ****
WARNING  Menu item action "RenameVideo" not implemented
WARNING  Menu item action "FastForward" not implemented
WARNING  Menu item action "Rewind" not implemented
WARNING  Menu item action "UpVolume" not implemented
WARNING  Menu item action "DownVolume" not implemented
INFO     Creating video display...
INFO     Finished startup sequence
INFO     loaded renderer 'xinerenderer'
WARNING! setupDummyBrowser failed
WARNING  Error setting up drag and drop dummy element
WARNING! setupDragAndDrop failed
INFO     First URL is https://www.miroguide.com/firsttime
TIMING   idle (select initial tab) too slow (0.779 secs)
WARNING! setupDragAndDrop failed
INFO     *** Daemon ready ***
INFO     Checking for updates...
INFO     Up to date.
TIMING   timeout (Save database) too slow (1.129 secs)
TIMING   idle (updateFinished() (using asIdle)) cumulative is too slow (5.116 secs)
TIMING   timeout (Save database) too slow (0.568 secs)
TIMING   idle (updateFinished() (using asIdle)) too slow (0.765 secs)
TIMING   idle (updateFinished() (using asIdle)) too slow (0.610 secs)
TIMING   idle (updateFinished() (using asIdle)) cumulative is too slow (5.288 secs)
TIMING   idle (updateFinished() (using asIdle)) too slow (0.511 secs)
TIMING   idle (updateFinished() (using asIdle)) too slow (0.504 secs)
TIMING   idle (updateFinished() (using asIdle)) cumulative is too slow (5.272 secs)
TIMING   WARNING: Calling <function <lambda> at 0x7f0702fae320> on HTTPClient:
http://www.jpl.nasa.gov/multimedia/podcast/planets-300.jpg too slow (1.031 secs)
TIMING   idle (updateFinished() (using asIdle)) too slow (0.572 secs)
INFO     Shutting down Downloader...
INFO     Shutting down downloaders...
INFO     Shutdown complete
INFO     Closing Database...
INFO     Shutting down event loop
INFO     Shutting down frontend
INFO     Saving preferences...
INFO     Shutting down icon cache updates
INFO     Shutting down movie data updates
INFO     Done shutting down.
INFO     Remaining threads are:
INFO     <_MainThread(MainThread, started)>

Comment 1 Alex Lancaster 2008-06-20 04:35:07 UTC

*** This bug has been marked as a duplicate of 452115 ***


Note You need to log in before you can comment on or make changes to this bug.