Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452134 - Regarding Virtual Machine
Summary: Regarding Virtual Machine
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt
Version: 5.2
Hardware: All
OS: Linux
low
urgent
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Don Domingo
URL: http://www.hclinfosystems.in
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 15:24 UTC by certification
Modified: 2008-12-03 05:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-03 05:26:51 UTC


Attachments (Terms of Use)
from -- /etc/Xen/Guest (deleted)
2008-07-08 13:10 UTC, certification
no flags Details

Description certification 2008-06-19 15:24:16 UTC
Probleb Regarding Virtual Machine.

In virtual machine CDROM Drive is sensing but we unable to access or mount any 
cdrom.

While doing certification CDROM test also enables but it gets failes always 
because CDROM drive is unable access.

Kernel Version 2.6.18-92
OD RHEL 5.2 
Test kit version :hts5.2

Comment 1 certification 2008-06-23 11:52:51 UTC
Dear Team,

Problem Regarding Virtual Machine.

In virtual machine CDROM Drive is sensing but we unable to access or mount any 
cdrom.

While doing certification CDROM test also enables but it gets fails always 
because CDROM drive is unable to access.

Kernel Version 2.6.18-92
OS RHEL 5.2 
Test kit version :hts5.2

Please help us to solve this problem.

Regards,

P.Ramanujam

Comment 3 Christopher Curran 2008-06-25 01:08:09 UTC
This bug is unlikely a bug for the Virtualization Guide. I suspect this bug
belongs to another component, most likely Xen or libvirt.

Comment 4 certification 2008-06-25 03:37:02 UTC
Dear Team,

Yes. This is belongs Xen / Libvert.
How to solve this problem.
Please help.

Regards.
Ramanujam

Comment 5 certification 2008-06-30 06:00:45 UTC
Dear TEam,

Still we have the same issue please help us to solve this issue

Ramanujam

Comment 7 certification 2008-07-08 08:41:00 UTC
Dear Team,

In virtual machine we unable to access CDROM.
While we try to do certification with RHEL5.2 it is enables CDROM test also so 
this CDROM test gets always fail.
Please help us to solve this issue.
Kernel Version 2.6.8.92
hts version hts-16
Regards
Ramanujam

Comment 8 Daniel Berrange 2008-07-08 09:36:57 UTC
Please provide your guest config file from /etc/xen/GUEST-NAME and the XML
config from 'virsh dumpxml GUEST-NAME' while the guest is running.


Comment 9 certification 2008-07-08 13:10:27 UTC
Created attachment 311262 [details]
from   -- /etc/Xen/Guest

I have attached /etc/xen/guest file for your reference

Regards
Ramanujam

Comment 10 certification 2008-07-08 13:12:22 UTC
Dear Team,

I have attached /etc/xen/guest file from xen kernel.
Please help me solve this issue shortly.

Ragards
Ramanujam

Comment 11 Cole Robinson 2008-07-15 15:58:18 UTC
I'm a bit confused what the problem is. Please explain the exact process you are
using to create the guest. What distro is in the guest?

If you are using virt-manager or virt-install please provide 'virsh dumpxml
GUESTNAME'.

Also, what exactly is the error message you are seeing? Are you trying to
install the guest off a cdrom, or just trying to mount the cdrom in an existing
guest?

From the xm config file your provided above, it looks like you are trying to run
a guest with /var/lib/xen/images/guest.img: is guest.img a bootable cdrom? Is it
just a RHEL 5.2 boot.iso, or some other iso that we can easily obtain to try and
reproduce this bug?

Comment 12 Narayanan 2008-07-16 04:30:51 UTC
Dear Team,

Now i will explain the exact problem.

Problem 1
=========
I am using RHEL5.2 Kernel Version is 2.6.8-92

I created Virtual machine There also i used RHEL5.2 i mean in Virtual OS also 
RHEL5.2.

After succesfull installaation i could able to see CDROM appearing in COMPUTER.

I mean CDROM is appearing in virtual OS. this feature is not availabel in 
earlier version of RHEL5.2.

Than i tried to use CDROM in Virtual machine. I put a CD in CDROM and i tried 
to read the content. But i can not do that Because CDROM is not mounting in 
Virtual OS.

My exact problem is why i unable to use CDROM in Virtual OS.

Please help me to Solve this issue.

I want to use CDROM in Virtual OS.

Problem 2
=========
 Now i am doing certification in RHEL5.2 in all the systems.
while i tried to do certification in Virtual machine CDROM always gets fail 
because of above said problem.

Please help to solve this issue also.

This is common issue in all systems so it si common issue.

Kernel version i used Kernel 2.6.8-92.el5
Test tool version     hts 5.2-16

I hope i could explain

Regards 
P.Ramanujam


Comment 13 Anuj Verma (Kevin) 2008-07-16 05:59:37 UTC
All, 

This is to confirm that as of now CDROM test under FV GuestOS is not a
requirement for HW Certification. 

Red Hat HwCert team does not include FV CDROM test in catalog test-plan
requirement, hence HCL can ignore the same even if HTS tools adds CDROM to the
HTS-plan for system under certification. 

Kevin Verma 

Comment 14 Anuj Verma (Kevin) 2008-12-03 05:26:51 UTC
Dear HCL Team, 

You were pointed out that bugzilla is not a support and interaction tool, I am closing this bug. 
Please use assistance guidelines as described in Hardware Certification Policy. 
(https://hardware.redhat.com/doc/sect-Hardware_Certification_Policy_Guide-Introduction-Requests_for_Assistance.html) 

Regards,
Kevin Verma


Note You need to log in before you can comment on or make changes to this bug.