Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452133 - mutt configured for aspell, but built without support
Summary: mutt configured for aspell, but built without support
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mutt
Version: 8
Hardware: All
OS: All
low
low
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 15:19 UTC by Moritz Barsnick
Modified: 2008-06-25 10:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-25 10:40:02 UTC


Attachments (Terms of Use)

Description Moritz Barsnick 2008-06-19 15:19:04 UTC
Description of problem:
mutt is explicitely configured for aspell (instead of ispell) in the SPEC file, 
but it doesn't even have support for either built in.

Version-Release number of selected component (if applicable):
1.5.18-2

How reproducible:
always

Steps to Reproduce:
1. mutt -v
2.
3.
  
Actual results:
-ISPELL

Expected results:
ISPELL="/usr/bin/ispell"

Additional info:
- It looks like mutt requires the presence of an ispell binary in order to 
build support for it. Stupid, huh? So, first line fix would be:
BuildRequires: aspell
(if it is really desired, but why not?).

- Perhaps ./configure should be patched to also detect the aspell binary. The 
ispell binary it detects here (with the above fix) is the comaptibility script.

- I checked this with the F8 SRPM, but it should be valid for all current 
builds, i.e. F8, F9, rawhide^Wdevelopment.

Comment 1 Miroslav Lichvar 2008-06-19 15:45:35 UTC
That's just a cosmetic issue. -ISPELL in the output means there is no hardcoded
path in mutt, but the support is still compiled in.

In /etc/Muttrc is the following line to use the aspell's email mode.

set ispell="/usr/bin/aspell --mode=email check"

Comment 2 Miroslav Lichvar 2008-06-25 10:40:02 UTC
mutt-1.5.18-3.fc10 buildrequires aspell.


Note You need to log in before you can comment on or make changes to this bug.