Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452119 - flow to disk to avoid memory exhaustion
Summary: flow to disk to avoid memory exhaustion
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 1.0
Hardware: All
OS: Linux
low
medium
Target Milestone: 1.1
: ---
Assignee: Gordon Sim
QA Contact: Kim van der Riet
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 14:49 UTC by Sergei Vorobiev
Modified: 2008-10-14 16:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-14 16:07:53 UTC


Attachments (Terms of Use)

Description Sergei Vorobiev 2008-06-19 14:49:13 UTC
When a transient queue with transient messages reaches pre-configured maximum
size , a messaging broker process should start committing the queue to disk with
expected performance impact to new incoming messages. This is required to
prevent memory exhaustion if messages are not retrieved from the queue by a
client, while new messages continue to arrive.

Comment 1 Gordon Sim 2008-06-20 08:26:58 UTC
*** Bug 446213 has been marked as a duplicate of this bug. ***

Comment 2 Gordon Sim 2008-07-01 08:37:33 UTC
We already do this for transient messages on durable queues which may be sufficient.

Comment 3 Gordon Sim 2008-10-14 16:07:53 UTC
Confirmed that flow to disk of transient (and durable) messages on durable queues is suffient here for now.


Note You need to log in before you can comment on or make changes to this bug.