Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452093 - Xorg does not start up after kernel upgrade to 2.6.25.7-65.fc9
Summary: Xorg does not start up after kernel upgrade to 2.6.25.7-65.fc9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 10:33 UTC by Joachim Frieben
Modified: 2008-06-22 10:31 UTC (History)
0 users

Fixed In Version: kernel-2.6.25.7-68.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-22 10:31:57 UTC


Attachments (Terms of Use)
Xorg.0.log in case of failed system boot procedure. (deleted)
2008-06-19 10:33 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2008-06-19 10:33:39 UTC
Description of problem:
After upgrading to the latest F9 kernel build 2.6.25.7-65.fc9, Xorg
stops working on an ATI Radeon X800. During start-up, the monitor
goes to power saving mode due to a missing video signal. The system
needs a hard reset to reboot.

Version-Release number of selected component (if applicable):
kernel-2.6.25.7-65.fc9.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot F9 with kernel 2.6.25.7-65.fc9.
  
Actual results:
Monitor goes to power saving mode. System is locked.

Expected results:
Boot-up procedure completes successfully.

Additional info:
- The latest entry in the changelog reads
    * Fri Jun 20 2008 Dave Airlie <airlied@redhat.com> 2.6.25.7-65
    - update radeon patches to newer upstream
  which is obviously the cause of the issue.
- Reverting to kernel-2.6.25.7-64.fc9 restores normal operation.

Comment 1 Joachim Frieben 2008-06-19 10:33:39 UTC
Created attachment 309843 [details]
Xorg.0.log in case of failed system boot procedure.

Comment 2 Joachim Frieben 2008-06-21 11:01:04 UTC
Issue also occurs for kernel-2.6.25.7-65.fc9.i686 after reverting to
the x86 version of Fedora 9.


Note You need to log in before you can comment on or make changes to this bug.