Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452092 - ogg123: crash when libvorbis rejects incorrect stream
Summary: ogg123: crash when libvorbis rejects incorrect stream
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vorbis-tools
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Kamil Dudka
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 10:29 UTC by Tomas Hoger
Modified: 2013-04-12 19:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-10 13:56:11 UTC


Attachments (Terms of Use)
Patch for ogg123 to stop reading stream when decoder reports stream error (deleted)
2008-06-19 10:29 UTC, Tomas Hoger
no flags Details | Diff

Description Tomas Hoger 2008-06-19 10:29:26 UTC
Description of problem:

ogg123 does not properly handle errors reported by vorbis decoder.  If vorbis
detects stream error, ogg123 attempts to continue reading the stream, resulting
in a crash.

Version-Release number of selected component (if applicable):

vorbis-tools-1.1.1-3.el5

Steps to Reproduce:

1. get 003.ogg, 004.ogg or 005.ogg from
   http://static.dataspill.org/releases/ogg/examples/

2. try to play it in ogg123

   $ ogg123 -d null 003.ogg

   Audio Device:   Null output

   Floating point exception

Expected results:

ogg123 should report error, if error was detected by vorbis.

Additional info:

Probably also affects all prior vorbis-tools versions shipped in Red Hat
Enterprise Linux (confirmed on RHEL3-RHEL5).

Fixed upstream as part of the following commit (last hunk):

  https://trac.xiph.org/changeset/12188

Proposed minimal patch attached.

Comment 1 Tomas Hoger 2008-06-19 10:29:26 UTC
Created attachment 309842 [details]
Patch for ogg123 to stop reading stream when decoder reports stream error

Comment 2 RHEL Product and Program Management 2008-07-21 23:01:05 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 3 RHEL Product and Program Management 2009-03-26 16:46:44 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 8 Kamil Dudka 2011-08-10 13:56:11 UTC
Thanks for the bug report.  We are sorry, but it is too late in the RHEL-5
release cycle.  I am closing this bugzilla WONTFIX.  If the issue is critical
for your business, please contact Red Hat Product Support - and inform them
about this bugzilla.


Note You need to log in before you can comment on or make changes to this bug.