Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452085 - HTS server is not verified when setting --server option
Summary: HTS server is not verified when setting --server option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness)
Version: 5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact:
URL:
Whiteboard:
: 446337 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 08:49 UTC by lihuang
Modified: 2009-01-27 22:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-27 22:58:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0047 normal SHIPPED_LIVE hts bug fix update 2009-01-27 22:57:30 UTC

Description lihuang 2008-06-19 08:49:28 UTC
Description of problem:
1.The plan is generated on test machine when the the specified test server stopped.
2.Warning message is not given.

Version-Release number of selected component (if applicable):
HTS 5.2 R16

How reproducible:
Every time

Steps to Reproduce:
1.issue "hts server stop" on the specified test server.
2.issue "ifconfig" on the specified test server to get the IP address(X.X.X.X)
3.issue "hts plan --server X.X.X.X on test machine.
  
Actual results:
The plan is generated on test machine and no warning message is given.

Expected results:
The Plan is not generated and warning message is given

Additional info:
In the following cases,warning/notice message also not given
1.Disable specified test which has already disabled in the test plan by issuing
" hts plan --disable --test specified_component_name".
2.Enable specified test which has already enabled in the test plan by issuing "
hts plan --enable --test specified_component_name".
3.Add specified test which has already added in the test plan by issuing " hts
plan --add --test specified_component_name".
4.Print the failed tests' results when there is no failed tests exist by issuing
" hts print --failure "

Comment 1 Greg Nichols 2008-06-19 12:55:13 UTC
Clarifying summary.

Comment 2 Greg Nichols 2008-06-23 14:32:52 UTC
*** Bug 446337 has been marked as a duplicate of this bug. ***

Comment 3 Greg Nichols 2008-07-01 16:21:20 UTC
Made this bug specific to --server issue.

Comment 4 Greg Nichols 2008-08-22 01:35:30 UTC
Fixed in HTS 5.2 R19

Comment 5 Greg Nichols 2008-08-28 01:42:55 UTC
Delayed to HTS 5.3

Comment 6 Yan Tian 2009-01-03 04:12:25 UTC
Verified the plan was generated on test machine when the the specified test server stopped and the warning message was given in hts-5.3-12.

Comment 8 errata-xmlrpc 2009-01-27 22:58:36 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html


Note You need to log in before you can comment on or make changes to this bug.