Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452080 - gpk-update-viewer crashes
Summary: gpk-update-viewer crashes
Keywords:
Status: CLOSED DUPLICATE of bug 456513
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 453823 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 08:16 UTC by Timon
Modified: 2008-10-27 13:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-27 13:12:23 UTC


Attachments (Terms of Use)
bug-buddy report (deleted)
2008-06-19 08:16 UTC, Timon
no flags Details
gdb backtrace (deleted)
2008-06-25 10:24 UTC, Timon
no flags Details
real gdb backtrace (deleted)
2008-06-25 10:28 UTC, Timon
no flags Details
callgrind (deleted)
2008-06-26 09:07 UTC, Timon
no flags Details
backtrace from gdb (deleted)
2008-07-04 09:54 UTC, JanS
no flags Details
gpk-update-viewer-bugreport (deleted)
2008-07-27 14:28 UTC, JanS
no flags Details
gpk-update-viewer output, run by user, after update from testing (deleted)
2008-07-27 14:31 UTC, JanS
no flags Details
Bug Buddy report (deleted)
2008-07-30 11:06 UTC, Antonio
no flags Details

Description Timon 2008-06-19 08:16:11 UTC
[timon@localhost ~]$ rpm -q gnome-packagekit
gnome-packagekit-0.1.12-14.20080516.fc9.2.i386

bug-buddy report in attachment

Comment 1 Timon 2008-06-19 08:16:11 UTC
Created attachment 309826 [details]
bug-buddy report

Comment 2 Richard Hughes 2008-06-22 15:14:27 UTC
Could you run gpk-update-viewer under gdb and attach the backtrace here please?
Thanks.

Comment 3 Timon 2008-06-25 10:24:49 UTC
Created attachment 310248 [details]
gdb backtrace

Comment 4 Timon 2008-06-25 10:28:18 UTC
Created attachment 310249 [details]
real gdb backtrace

sorry :)

Comment 5 Richard Hughes 2008-06-25 14:00:11 UTC
David, PolicyKit bug?

Comment 6 David Zeuthen 2008-06-25 15:26:23 UTC
(In reply to comment #5)
> David, PolicyKit bug?

Unlikely, haven't seen other PolicyKit bugs about crashing. More like
bad/corrupt data being passed to the library.

Comment 7 Timon 2008-06-26 09:07:13 UTC
Created attachment 310315 [details]
callgrind

valgrind --tool=callgrind gpk-update-viewer
maybe this info can help you

Comment 8 Richard Hughes 2008-07-04 09:39:37 UTC
*** Bug 453823 has been marked as a duplicate of this bug. ***

Comment 9 JanS 2008-07-04 09:54:17 UTC
Created attachment 311023 [details]
backtrace from gdb

#0  0x00000039a8404560 in _compute_polkit_result (action=<value optimized out>)
at polkit-gnome-action.c:800
#1  0x00000039a8406038 in set_property (object=<value optimized out>,
prop_id=<value optimized out>, value=<value optimized out>,
    pspec=<value optimized out>) at polkit-gnome-action.c:1129
#2  0x000000399c410ae0 in ?? () from /lib64/libgobject-2.0.so.0
#3  0x00000039a84060a9 in polkit_gnome_action_constructor (type=<value
optimized out>, n_construct_properties=<value optimized out>,
    construct_properties=<value optimized out>) at polkit-gnome-action.c:381
#4  0x000000399c411063 in g_object_newv () from /lib64/libgobject-2.0.so.0
#5  0x000000399c411aab in g_object_new_valist () from
/lib64/libgobject-2.0.so.0
#6  0x000000399c411cfc in g_object_new () from /lib64/libgobject-2.0.so.0
#7  0x00000039a8404ae7 in polkit_gnome_action_new_default (name=<value
optimized out>, polkit_action=<value optimized out>, label=<value optimized
out>,
    tooltip=<value optimized out>) at polkit-gnome-action.c:1061
#8  0x0000000000406716 in main (argc=1, argv=0x7fffd2fd01e8) at
gpk-update-viewer.c:1910


Whole output from gdb on attachment

Comment 10 JanS 2008-07-27 11:48:41 UTC
Is this bug under investigation?

I am still experiencing constant crashes of gpk-update-viewer as user.
As root I can run it, but I cannot update. So it is hard to update only some of
the packages. All or nothing.


Comment 11 Richard Hughes 2008-07-27 13:08:43 UTC
JanS, can you try the packages in updates-testing please? You only have to
update gnome-packagekit and PackageKit.

Comment 12 JanS 2008-07-27 14:27:09 UTC
I have updated gnome-packagekit and PackageKit from update-testing.
Yum shown some errors during procedure, when updating gnome-packagekit:

many errors like:
  Unknown media type in type 'print/class'
  Unknown media type in type 'fonts/package'

and after cleanup:

ERROR:dbus.connection:Unable to set arguments () according to signature u's':
<type 'exceptions.TypeError'>: More items found in D-Bus signature than in
Python arguments
Unable to send message to PackageKit"



And gpk-update-viewer still was crashing.

Only after total reboot of machine it works.


There was an additional issue before reboot. When gpk-update-viewer was run by
root (because when run by user was crashing) when going to Review, Getting
details... was always working and never ending.
For eg. this process was still on:
root     31462 29873  4 44696 16544   1 15:45 ?        00:00:00 /usr/bin/python
/usr/share/PackageKit/helpers/yum/get-update-detail.py
kernel-devel;2.6.25.11-97.fc9;x86_64;updates

only kill -9 was needed. Any subsequent try to get update detailes ended same
way, and get-update-detail.py was hanging all the time.

Now after reboot almost everything works. Except that update detailes are still
not cached (bug 453986).


Comment 13 JanS 2008-07-27 14:28:55 UTC
Created attachment 312730 [details]
gpk-update-viewer-bugreport

Comment 14 JanS 2008-07-27 14:31:08 UTC
Created attachment 312731 [details]
gpk-update-viewer output, run by user, after update from testing

Comment 15 JanS 2008-07-27 14:38:55 UTC
ATTENTION. I now wy after reboot it worked!

Its because I had not any programs running, especially Firefox.

Now when I had started Firefox gpk-update-viewer crashes again.
When I am closing Firefox, gpk-update-viewer works.
When I am starting it, gpk-update-viewer crashes, an so on...

Additional info:
  firefox.x86_64                           3.0.1-1.fc9


Comment 16 Antonio 2008-07-30 11:06:18 UTC
Created attachment 312983 [details]
Bug Buddy report

I found an interesting relationship: removing the Notification Area (2.22.2 in
my case), the gpk-application runs seamless....

Comment 17 aravind.parchuri 2008-08-28 01:14:29 UTC
I can confirm this bug, it seems to be a generic problem with gnome apps using packagekit. See bug 456513.

Comment 18 Richard Hughes 2008-10-27 13:12:23 UTC
Okay. thanks.

*** This bug has been marked as a duplicate of bug 456513 ***


Note You need to log in before you can comment on or make changes to this bug.