Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452054 - Use of the Symbol Viewer plugin crashes kate
Summary: Use of the Symbol Viewer plugin crashes kate
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdesdk
Version: 9
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 01:04 UTC by Ian Laurie
Modified: 2008-06-25 02:51 UTC (History)
5 users (show)

Fixed In Version: 4.0.5-3.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-25 02:51:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 156559 None None None Never

Description Ian Laurie 2008-06-19 01:04:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
The Symbol Viewer plugin crashes kate.  The crash will happen every time a session is saved in which the plugin is active, or when kate exits if kate is set to save the session on exit.

Version-Release number of selected component (if applicable):
kdesdk-4.0.5-2.fc9.i386

How reproducible:
Always


Steps to Reproduce:
1. Launch Kate
2. Activate the Symbol Viewer
3. Save the current session


Actual Results:
Kate crashes when trying to save the session.  The updated session is not saved.  That is, when you restart kate, the Symbol Viewer plugin is not active.

Expected Results:
It should save the session.

Additional info:
If you save a session with a modified file, the edits are lost due to the crash.

Comment 1 Steven M. Parrish 2008-06-20 21:04:20 UTC
Per upstream report http://bugs.kde.org/show_bug.cgi?id=156559 this is a known
issue and has been corrected in 4.1.  Thanks for the report.

Comment 2 Ian Laurie 2008-06-23 00:58:45 UTC
Will the fix be released as a fedora 9 update?



Comment 3 Kevin Kofler 2008-06-23 01:01:21 UTC
The plan is to release 4.1 as a F9 update once it's released, maybe we'll push 
a backported fix sooner.

Comment 4 Kevin Kofler 2008-06-23 05:12:39 UTC
What bugs me is that that fix is 4 months old and was never backported to 4.0, 
somehow the upstream process is broken there. :-/

Comment 5 Kevin Kofler 2008-06-23 05:15:26 UTC
Backporting fix.

Comment 6 Kevin Kofler 2008-06-23 05:22:01 UTC
Fixed F9 build here: http://koji.fedoraproject.org/koji/taskinfo?taskID=675978

Comment 7 Fedora Update System 2008-06-23 06:24:10 UTC
kdesdk-4.0.5-3.fc9 has been submitted as an update for Fedora 9

Comment 8 Ian Laurie 2008-06-23 06:27:55 UTC
New build works for me.  Thank you for the fast resolution to the problem.

Comment 9 Kevin Kofler 2008-06-23 06:31:58 UTC
And thanks for your fast feedback. The update is heading straight to the stable 
updates.

Comment 10 Fedora Update System 2008-06-25 02:51:48 UTC
kdesdk-4.0.5-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.