Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452045 - xulrunner-1.9-1.fc9 breaks RSSOwl 2.0
Summary: xulrunner-1.9-1.fc9 breaks RSSOwl 2.0
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 10
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-18 22:38 UTC by Dennis Jacobfeuerborn
Modified: 2018-04-11 08:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-29 02:20:40 UTC


Attachments (Terms of Use)
RSSOwl debug output (deleted)
2008-06-18 22:38 UTC, Dennis Jacobfeuerborn
no flags Details

Description Dennis Jacobfeuerborn 2008-06-18 22:38:17 UTC
The final version of xulrunner 1.9 breaks RSSOwl which fails in libxul.so. See
the attached debug log for details.

Reverting back to package xulrunner-1.9-0.63.beta5.fc9 fixes the problem.

Comment 1 Dennis Jacobfeuerborn 2008-06-18 22:38:17 UTC
Created attachment 309803 [details]
RSSOwl debug output

Comment 2 Martin Stransky 2008-06-19 09:26:06 UTC
Hm, I see dead.package in rssowl/F9 and devel. What's up?

Comment 3 Dennis Jacobfeuerborn 2008-06-19 15:47:05 UTC
I'm using the file from the rssowl homepage since there is no package for fedora
right now:
http://downloads.sourceforge.net/rssowl/rssowl-2.0-M8a.linux.gtk.x86.zip


Comment 4 Martin Stransky 2008-06-20 08:44:49 UTC
Then report this bug at rssowl upstream. We can't fix it when the package is not
in fedora.

Comment 5 Dennis Jacobfeuerborn 2008-06-20 20:23:30 UTC
I'm not reporting a bug in RSSOwl but in xulrunner.

The bug is only is clearly and reproducably triggered by the new fedora
xulrunner package and the debug log shows the segfault occuring in libxul.so
which is part of that xulrunner package.

Other people are reporting a similar problem for other apps too on fedora-devel
(Miro is one of the affected applications apparently).


Comment 6 Ismael Juma 2008-06-20 21:52:39 UTC
Hi Dennis,

There are some nightlies for RSSOwl here:

http://rssowl.pluginbuilder.org/latest/

They use a newer Eclipse RCP build that _may_ solve the problem for you. I am
using Fedora 9 with a RSSOwl without problems.

Having said that, there was a bug filed in Eclipse bugzilla about some issues
with the browser with the latest version too:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=236724

Comment 7 Matěj Cepl 2008-06-20 22:09:38 UTC
Throwing the bug over the fence to Eclipse guys, because hopefully they could
have more clue about what's going on.

Comment 8 Matěj Cepl 2008-06-20 22:10:11 UTC
Reporter, would you please try some of these nightlies whether it works better
for you?

Comment 9 Dennis Jacobfeuerborn 2008-06-20 23:21:42 UTC
Yep, the nightly starts up fine with the final version of the xulrunner package.

Comment 10 Paul Michael Reilly 2008-06-22 04:52:18 UTC
FWIW, I verified that using the Fedora version of Eclipse with the Fedora
version of Firefox 3 (both using the most recent updates as of this comment)
works properly but that using the F9 Firefox 3 (really xulrunner) does not work
with the Eclipse 3.3.2 Classic installed from eclipse.org, i.e. it breaks with
the same signature in the debug log filed by the reporter.  So this is clearly
not a Fedora bug per se but I'd hazard a guess that the xulrunner Fedora
maintainer could easily debug and report upstream to either Eclipse or Mozilla
how to resolve the upstream issue.  Meanwhile I'll count my blessing that Fedora
has their collective act together on the Eclipse/Firefox/Java chain ... for now. :-)

-pmr


Comment 11 Paul Michael Reilly 2008-06-22 05:02:24 UTC
I probably should have added that to see the actual breakage is easy:

1) create a new workspace, say ~/452045/workspace.
2) download eclipse classic from the eclipse.org download site.
2) start the downloaded Eclipse and select ~/452045/workspace.

Wham, a jvm crash is reported showing a xulrunner sigsegv.  I would hazard a
guess that anyone astute enough to connect gdb and the offending xulrunner
(which leaves me out) will be able to provide useful information to the upstream
maintainers for either Eclipse or xulrunner.  I'd guess Eclipse since the F9
eclipse/xulrunner pair seems pretty content.  It almost feels as if there is a
static binding rather than dynamic but I'm way over my head at this point so
I'll stop right here.

-pmr


Comment 12 Andrew Overholt 2008-06-23 15:43:03 UTC
So is this the same as bug #452929?

Comment 13 Andrew Overholt 2008-06-23 18:56:40 UTC
It looks like (and is confirmed by Paul's comment #10) this only affects
upstream builds, right?

Comment 14 Bug Zapper 2008-11-26 02:26:37 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 15 Dennis Jacobfeuerborn 2009-04-29 02:20:40 UTC
This isn't a problem with current builds of RSSOwl 2.0 anymore => closing


Note You need to log in before you can comment on or make changes to this bug.