Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452030 - '/dev' folder is world writable
Summary: '/dev' folder is world writable
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-18 19:43 UTC by petrosyan
Modified: 2008-11-19 04:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-19 04:24:19 UTC


Attachments (Terms of Use)

Description petrosyan 2008-06-18 19:43:18 UTC
Description of problem:
'/dev' folder is world writable

Version-Release number of selected component (if applicable):
Fedora rawhide

Steps to Reproduce:
ls -ld /dev
  
Actual results:
http://jmtaylor.fedorapeople.org/rawhide.png

Expected results:
$ ls -ld /dev/
drwxr-xr-x 14 root root 4140 2008-06-18 12:47 /dev/

Comment 1 Phil Knirsch 2008-06-19 13:21:30 UTC
Thats really strange. I've just checked the latest package, here the filelist:

[phil@localhost tmp]$ rpm -qpvl filesystem-2.4.16-1.fc10.i386.rpm | head -10
drwxr-xr-x    2 root    root                0 Jun 18 16:43 /
drwxr-xr-x    2 root    root                0 Jun 18 16:43 /bin
drwxr-xr-x    2 root    root                0 Jun 18 16:43 /boot
drwxr-xr-x    2 root    root                0 Jun 18 16:43 /dev
drwxr-xr-x    2 root    root                0 Jun 18 16:43 /etc
drwxr-xr-x    2 root    root                0 Jun 18 16:43 /etc/X11
drwxr-xr-x    2 root    root                0 Jun 18 16:43 /etc/X11/applnk
drwxr-xr-x    2 root    root                0 Jun 18 16:43 /etc/X11/fontpath.d
drwxr-xr-x    2 root    root                0 Jun 18 16:43 /etc/fonts
drwxr-xr-x    2 root    root                0 Jun 18 16:43 /etc/fonts/conf.d

So some other process seems to be modifying /dev, not a whole lot i can about in
filesystem itself.

Could you maybe investigate which process did it? Possible suspects would be
udev or hal/dbus maybe.

Thanks,

Read ya, Phil

Comment 2 Jason Taylor 2008-06-20 20:46:45 UTC
Fresh rawhide install from 19-Jun-2008 had permissions set as shown in the
original post. setting the perms to what they are in F9 causes udev to blowup.
Would this point to it being the udev package being the culprit? or is this a
false positive type thing? 

Comment 3 Harald Hoyer 2008-06-21 08:46:36 UTC
maybe something in initrd changed?

Comment 4 Jason Taylor 2008-06-21 13:48:05 UTC
So after a reinstall of rawhide, the permissions are still wrong, when I change
them to what they should be, now the system boots and resets the perms.
Screenshots below.

http://jmtaylor.fedorapeople.org/before.reboot.png

http://jmtaylor.fedorapeople.org/after.reboot.png

I will keep looking to see what else I can dig up.

Comment 5 Jason Taylor 2008-06-21 13:58:46 UTC
Here is udev debug output, which shows some segfaulting which I hadn't noticed
before.

http://jmtaylor.fedorapeople.org/udev.out.txt

Comment 6 Harald Hoyer 2008-06-25 06:14:14 UTC
tried to make a rawhide virtual machine, but did not succeed (bug 452799)

with the old initrd and new udev, /dev has normal permissions.. so I suspect
mkinitrd/nash to set the wrong permissions.

Comment 7 Warren Togami 2008-11-19 02:58:54 UTC
Could you please test if this is still an issue?  A similar issue was solved for F-10 in Bug #471142.

Comment 8 petrosyan 2008-11-19 04:24:19 UTC
This bug has been resolved in Fedora rawhide.


Note You need to log in before you can comment on or make changes to this bug.