Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451980 - Package perl-Convert-ASN1 should be taken from RHEL channel and removed from ISO
Summary: Package perl-Convert-ASN1 should be taken from RHEL channel and removed from ISO
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer
Version: 510
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Steve Salevan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-18 14:41 UTC by Jan Pazdziora
Modified: 2008-11-05 18:40 UTC (History)
1 user (show)

Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-05 18:40:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Pazdziora 2008-06-18 14:41:21 UTC
Description of problem:

The package perl-Convert-ASN1 is present both in RHEL 4 and in RHEL 5. We should
not ship our own (old) version.

Version-Release number of selected component (if applicable):

Satellite 5.1.0

How reproducible:

Deterministic.

Steps to Reproduce:
1. Mount Satellite ISO, cd to it.
2. Run find . -name 'perl-Convert-ASN1*'
3. Also look into the Satellite channel.
  
Actual results:

Rpm found.

Expected results:

Package not found and Satellite installs and operates normally.

Additional info:

Comment 1 Jan Pazdziora 2008-06-19 09:09:22 UTC
Checking in comps-rhel4-rhnsat52.xml;
/cvs/devel/comps/comps-rhel4-rhnsat52.xml,v  <--  comps-rhel4-rhnsat52.xml
new revision: 1.22; previous revision: 1.21
done
Checking in comps-rhel5-rhnsat52.xml;
/cvs/devel/comps/comps-rhel5-rhnsat52.xml,v  <--  comps-rhel5-rhnsat52.xml
new revision: 1.10; previous revision: 1.9
done

Checking in 4/RHN-Satellite-5.2/updates/rhelrpms.s390/rhelrpms;
/cvs/devel/rhelfiles/4/RHN-Satellite-5.2/updates/rhelrpms.s390/rhelrpms,v  <-- 
rhelrpms
new revision: 1.6; previous revision: 1.5
done
Checking in 4/RHN-Satellite-5.2/updates/rhelrpms.s390x/rhelrpms;
/cvs/devel/rhelfiles/4/RHN-Satellite-5.2/updates/rhelrpms.s390x/rhelrpms,v  <--
 rhelrpms
new revision: 1.6; previous revision: 1.5
done
Checking in 4/RHN-Satellite-5.2/updates/rhelrpms.x86_64/rhelrpms;
/cvs/devel/rhelfiles/4/RHN-Satellite-5.2/updates/rhelrpms.x86_64/rhelrpms,v  <--
 rhelrpms
new revision: 1.6; previous revision: 1.5
done
Checking in 5/RHN-Satellite-5.2/updates/rhelrpms;
/cvs/devel/rhelfiles/5/RHN-Satellite-5.2/updates/rhelrpms,v  <--  rhelrpms
new revision: 1.4; previous revision: 1.3
done


Comment 2 Brad Buckingham 2008-08-13 16:52:20 UTC
Mass move to ON_QA.

Comment 3 Steve Salevan 2008-08-18 20:01:10 UTC
Looks like this fix hasn't hit the latest candidate trees:

/mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20080813.1/i386/i386-global/Satellite/perl-Convert-ASN1-0.15-5.rhel4.noarch.rpm
/mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20080813.1/i386/i386-global/EmbeddedDB/perl-Convert-ASN1-0.15-5.rhel4.noarch.rpm
/mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20080813.1/x86_64/x86_64-global/Satellite/perl-Convert-ASN1-0.15-5.rhel4.noarch.rpm
/mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20080813.1/x86_64/x86_64-global/EmbeddedDB/perl-Convert-ASN1-0.15-5.rhel4.noarch.rpm
/mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20080813.1/s390/s390-global/Satellite/perl-Convert-ASN1-0.15-5.rhel4.noarch.rpm
/mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20080813.1/s390x/s390x-global/Satellite/perl-Convert-ASN1-0.15-5.rhel4.noarch.rpm
/mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20080813.1/s390x/s390x-global/EmbeddedDB/perl-Convert-ASN1-0.15-5.rhel4.noarch.rpm

Moving to FAILS_QA.

Comment 4 Jan Pazdziora 2008-08-18 21:33:47 UTC
The -global directories contain all rpms from brew. You should really look into $arch/$arch, e.g. i386/i386. That's where the composes are. Or just look at the ISOs.

Comment 5 Steve Salevan 2008-08-26 20:02:14 UTC
Checked on RHEL4/5 and Hosted Satellite Channel, package no longer exists.  Moving to VERIFIED.

Comment 6 Preethi Thomas 2008-10-22 12:51:31 UTC
release pending

Comment 7 Brandon Perkins 2008-11-05 18:40:40 UTC
5.2.0 Satellite is now GA, bugs Closed for Current Release.


Note You need to log in before you can comment on or make changes to this bug.