Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451979 - RFE: When install grub on a software raid 1 device, it should be put on all MBRs
Summary: RFE: When install grub on a software raid 1 device, it should be put on all MBRs
Keywords:
Status: CLOSED DUPLICATE of bug 160563
Alias: None
Product: Fedora
Classification: Fedora
Component: grub
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-18 14:40 UTC by Bruno Wolff III
Modified: 2008-06-18 14:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-18 14:46:27 UTC


Attachments (Terms of Use)

Description Bruno Wolff III 2008-06-18 14:40:59 UTC
Description of problem:
When doing an install of grub it only is placed on the MBR of one device. When
/boot is a software raid 1 device it would be convenient if it was installed on
all members of the array so that if the current boot disk is pulled the system
can be booted of one of the remaining disks. While it isn't 100% certain what
the name of the other drives will be when there is a failure, I think the most
common case is that the bad drive will be pulled or not visible to the BIOS and
that it will be hd0.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Bruno Wolff III 2008-06-18 14:46:27 UTC
Whoops, this is a duplicate of bug 160563.

*** This bug has been marked as a duplicate of 160563 ***


Note You need to log in before you can comment on or make changes to this bug.