Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451956 - galeon doesnt work anymore since updated xulrunner-0:1.9-1.fc9.x86_64
Summary: galeon doesnt work anymore since updated xulrunner-0:1.9-1.fc9.x86_64
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: galeon
Version: 9
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 452068 452191 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-18 11:30 UTC by Dams
Modified: 2008-06-20 06:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-18 11:38:01 UTC


Attachments (Terms of Use)

Description Dams 2008-06-18 11:30:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
I've upgraded xulrunner to xulrunner-0:1.9-1.fc9.x86_64 and now galeon doesnt start anymore. And now i'm sad :`(

Version-Release number of selected component (if applicable):
galeon-0:2.0.5-1.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1. galeon &


Actual Results:

** (galeon:4866): WARNING **: I could not load the bookmarks file, will load the default bookmarks from /usr/share/galeon/default-bookmarks.xbel.

** (galeon:4866): CRITICAL **: radio_group_set_from_value: assertion `action != NULL' failed
zsh: segmentation fault  galeon


Expected Results:


Additional info:
I've tried to rebuild galeon against new xulrunner, and it failed too : 

ContentHandler.cpp:301: error: prototype for 'nsresult GContentHandler::PromptForSaveToFile(nsIHelperAppLauncher*, nsISupports*, const PRUnichar*, const PRUnichar*, nsILocalFile**)' does not match any in class 'GContentHandler'
ContentHandler.h:49: error: candidate is: virtual nsresult GContentHandler::PromptForSaveToFile(nsIHelperAppLauncher*, nsISupports*, const PRUnichar*, const PRUnichar*, PRBool, nsILocalFile**)

I'm clueless when it comes to c++, so I wont try to make a patch by myself, sorry :p

Comment 1 Denis Leroy 2008-06-18 11:38:01 UTC
Build pushed.

http://koji.fedoraproject.org/koji/buildinfo?buildID=53017


Comment 2 Dams 2008-06-18 12:20:08 UTC
Many many thanks.

Comment 3 Denis Leroy 2008-06-19 06:50:15 UTC
*** Bug 452068 has been marked as a duplicate of this bug. ***

Comment 4 Denis Leroy 2008-06-20 06:39:20 UTC
*** Bug 452191 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.