Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451933 - iptables-1.3.8-7.fc8.i686.rpm not builded
Summary: iptables-1.3.8-7.fc8.i686.rpm not builded
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: iptables
Version: 8
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-18 08:42 UTC by Danilo Marcucci
Modified: 2008-07-09 21:49 UTC (History)
2 users (show)

Fixed In Version: 1.4.1.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-09 21:49:17 UTC


Attachments (Terms of Use)
File log (deleted)
2008-06-18 08:42 UTC, Danilo Marcucci
no flags Details

Description Danilo Marcucci 2008-06-18 08:42:49 UTC
Description of problem:
iptables-1.3.8-7.fc8.src.rpm not builded

Version-Release number of selected component (if applicable):
iptables-1.3.8-7.fc8.src.rpm

How reproducible:
rpmbuild --define "dist .fc8" --define "fedora 8" --rebuild --target i686
/usr/src/redhat/SRPMS/iptables-1.3.8-7.fc8.src.rpm

Steps to Reproduce:
1.
2.
3.
  
Actual results:
NOt builded

Expected results:
Builded iptables-1.3.8-7.fc8.i686.rpm

Additional info:
iptables-1.3.8-7.fc8.src.rpm.log created with these parameter:
rpmbuild --define "dist .fc8" --define "fedora 8" --rebuild --target i686
/usr/src/redhat/SRPMS/iptables-1.3.8-7.fc8.src.rpm 2>&1 | tee -a
iptables-1.3.8-7.fc8.src.rpm.log

Comment 1 Danilo Marcucci 2008-06-18 08:42:49 UTC
Created attachment 309705 [details]
File log

Comment 2 DaveG 2008-06-30 13:37:47 UTC
Same error for me - looks like the problems starts in
iptables-1.3.8/libiptc/ipt_kernel_headers.h, GLIBC version switch? Needs
<linux/types.h> for definition of __u32.

FYI:
iptables-1.3.8-7.fc8.src.rpm
kernel-2.6.25.6-27.fc8.x86_64
glibc-2.7-2.x86_64
gcc-4.1.2-33.x86_64
kernel-headers-2.6.25.6-27.fc8.x86_64
libselinux-devel-2.0.43-1.fc8.x86_64

Currently working on a patch for iptables to bring it in line with the kernel
package netfilter modules. Waiting to test it.

Comment 3 Danilo Marcucci 2008-07-01 09:10:54 UTC
I have this package:
#rpm -q kernel glibc  gcc kernel-headers libselinux-devel
kernel-2.6.25.6-27.fc8
glibc-2.7-2
gcc-4.1.2-33
kernel-headers-2.6.25.6-27.fc8
libselinux-devel-2.0.43-1.fc8

Do you have another suggestion or solution to building
iptables-1.3.8-7.fc8.src.rpm package in arch i686?


Comment 4 Thomas Woerner 2008-07-01 09:19:23 UTC
Oh, you are trying to build an 32 bit package on a 64 bit host. Please setup a
32 bit chroot and build your package in there.

Comment 5 Danilo Marcucci 2008-07-01 10:45:48 UTC
Sorry, i can't understand you.
I have a 32 bit system on 32bit hardware.
#uname -a
Linux builder.mynet.it 2.6.25.6-27.fc8 #1 SMP Fri Jun 13 16:38:52 EDT 2008 i686
i686 i386 GNU/Linux

#cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 1.80GHz
stepping        : 4
cpu MHz         : 1796.948
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm up pebs bts
bogomips        : 3597.77
clflush size    : 64

Why i trying to build a 32bit in a 32 bit system?
This is a system at 32bit not at 64bit.


Comment 6 DaveG 2008-07-01 11:45:02 UTC
I am trying to build an x86_64 package on an x86_64 host and it looks like
Danilo is trying to build i686 on an i686 host, i.e. f8, host=target for both of us.

`rpmbuild --rebuild iptables-1.3.8-7.fc8.src.rpm` produces the same error.

Am I missing something? Does it need a special incantation on the rpmbuild
command line?

Comment 7 Fedora Update System 2008-07-01 15:49:49 UTC
iptables-1.4.1.1-1.fc8 has been submitted as an update for Fedora 8

Comment 8 Fedora Update System 2008-07-02 06:31:28 UTC
iptables-1.4.1.1-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iptables'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5921

Comment 9 Danilo Marcucci 2008-07-02 09:34:27 UTC
I have get that package:
#wget
http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/iptables-1.4.1-1.fc10.src.rpm
I have rebuild it with this command and flag:
#rpmbuild --define "dist .fc8" --define "fedora 8" --rebuild --target i686
iptables-1.4.1-1.fc10.src.rpm
I have got builded packages in arch i686:
iptables-1.4.1-1.fc8.i686.rpm
iptables-ipv6-1.4.1-1.fc8.i686.rpm
iptables-devel-1.4.1-1.fc8.i686.rpm
I have update these package without any problem.

If you want, you can close this bug.

Best regads at everyone


Comment 10 DaveG 2008-07-02 11:39:37 UTC
Builds for me too (x86_64).
Happy to close this bug.

Thanks also,
-DaveG

Comment 11 Fedora Update System 2008-07-09 21:49:15 UTC
iptables-1.4.1.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.