Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451921 - kyum fails to parse some repo files correctly
Summary: kyum fails to parse some repo files correctly
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kyum
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-18 06:57 UTC by Vince Schiavoni
Modified: 2008-06-24 10:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 18:28:39 UTC


Attachments (Terms of Use)

Description Vince Schiavoni 2008-06-18 06:57:38 UTC
Description of problem:
kyum fails to read ("parse"?) repository files correctly, when the format of 
the repo file is like so:
[...]
baseurl=
        http://mirror.yandex.ru/fedora/tigro/$releasever/$basearch
        ftp://mirror.yandex.ru/fedora/tigro/$releasever/$basearch
        http://ftp.msiu.ru/pub/fedora/tigro/$releasever/$basearch
        ftp://ftp.msiu.ru/pub/fedora/tigro/$releasever/$basearch
[...]

In which case, kyum on the "Repository" tab shows for example (Note missing 
baseurl lines):

[tigro]
name=Tigro for Fedora $releasever - $basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-tigro

Also, any attempt to edit the repo file using kyum will blow away the "baseurl" 
lines that are not displayed.

Note that this is a legal format according to yum's rules of syntax.

Version-Release number of selected component (if applicable):
kyum-0.7.5-10.fc8.1.i386

How reproducible:
Always.

Steps to Reproduce:
1. Install kyum.
2. Install any repo file with above format.
3. Observe output as per example shown.
  
Actual results:
> kyum fails to read repo file and so no packages show up. Interestingly, the 
missing baseurl/mirrorlist does not cause a failed "cannot retreive repo.xml" 
or such (because yum itself does see those files?).
> kyum can effectively destroy a repo file by wiping out baseurl lines.

Expected results:
Correct parsing of "legal" repo files.

Additional info:
On request.

Comment 1 Jochen Schmitt 2008-06-18 15:21:30 UTC
That bug exist as Bug #1785258 in the upstram bug reporting system.

Comment 2 Vince Schiavoni 2008-06-18 16:16:49 UTC
I'm sorry, but it is patently obvious that this issue will not be fixed by the 
upstream source.

There are at least two bugs open and unassigned on this issue, the oldest from 
2005-11-20. In addition, no changes to the CVS source code have been made in 
over two years. It is painfully clear that the author is either dead, disabled, 
or has abandoned the project.

Please either address this issue with some solution, or remove the package from 
circulation as it is broken, can't/won't be fixed, and presents a hazard to use.

Thanx and Regards,
VJS

Comment 3 Jochen Schmitt 2008-06-23 17:51:06 UTC
OK, I have wrote a mail to the author about this topic. I have wrote, that the
package will been removed after a deadline, if they could not present any fixes
for the reported issues of the project.

Best Regards:

Jochen Schmitt

Comment 4 Jochen Schmitt 2008-06-23 18:28:39 UTC
Package is going to be retired, becouse the upstream autor has sent a quick
answer in which he wrote, that he has no time to maintain the project.

Comment 5 Vince Schiavoni 2008-06-24 10:45:10 UTC
Herr Schmitt:

Thank You. Obviously, this is not the preferable outcome. However, in lieu of a 
fix, I believe that it's better to retire the package than to leave it broken, 
and to continue to grow more stale and potentially harmful to users. I 
appreciate your taking action on this matter.

Thanks Again and Regards,
VJS


Note You need to log in before you can comment on or make changes to this bug.