Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451915 - Can't install multilib packages using GNOME PackageKit
Summary: Can't install multilib packages using GNOME PackageKit
Keywords:
Status: CLOSED DUPLICATE of bug 443143
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-18 04:16 UTC by Alex W. Jackson
Modified: 2008-07-15 14:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 14:33:06 UTC


Attachments (Terms of Use)

Description Alex W. Jackson 2008-06-18 04:16:42 UTC
Description of problem:
It seems to be impossible to use the GNOME PackageKit client to install the i386
version of a multilib package whose x86_64 version is already installed.  It
displays an error dialog saying "This package could not be installed as it is
already installed".

Version-Release number of selected component (if applicable):
gnome-packagekit-0.1.12-12.20080430.fc9

How reproducible:
always

Steps to Reproduce:
1.Have, e.g., SDL.x86_64 installed, but not SDL.i386
2.Run GNOME PackageKit
3.Select i386 version of SDL from list of available packages
4.Click install

Actual results:
"This package could not be installed as it is already installed"

Expected results:
package installs

Additional info:
Dunno if the problem is with gnome-packagekit, or PackageKit itself, or even
further down the stack (yum?) as I can't be arsed to figure out pkcon
syntax--for now I've fallen back to manually downloading and installing using
rpm -i.

Comment 1 Richard Hughes 2008-06-23 10:15:46 UTC
Sure, I've not got a multilib box here so I can't test this. Could you try
rebuilding PackageKit from rawhide and trying that? Thanks.

Comment 2 Julian Sikorski 2008-07-15 14:16:21 UTC
This is probably a duplicate of #443143.

Comment 3 Alex W. Jackson 2008-07-15 14:33:06 UTC
Yes, it is.

*** This bug has been marked as a duplicate of 443143 ***


Note You need to log in before you can comment on or make changes to this bug.