Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451914 - use pango lang tags for language list
Summary: use pango lang tags for language list
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F10Target
TreeView+ depends on / blocked
 
Reported: 2008-06-18 03:27 UTC by Jens Petersen
Modified: 2015-01-14 23:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-10 17:16:23 UTC


Attachments (Terms of Use)
lang-tag.patch (deleted)
2008-07-09 03:28 UTC, Matthias Clasen
no flags Details | Diff
Nihongo.png (deleted)
2008-07-10 00:25 UTC, Jens Petersen
no flags Details
better patch (deleted)
2008-07-10 05:11 UTC, Matthias Clasen
no flags Details | Diff

Description Jens Petersen 2008-06-18 03:27:01 UTC
Description of problem:
gdm just using the default font rendering for languages in its language list.
This hits the font ordering issues with pango for Unihan (ie particularly for
Chinese and Japanese in this case): with current fedora font defaults Japanese
gets displayed with a Chinese glyphs in a non-ja locale.

How reproducible:
every time

Steps to Reproduce:
1. install rawhide
2. boot, firstboot and go to gdm lang list
3. look at rendering of ja and zh entries
  
Actual results:
3. Japanese (日本語) is rendered with Chinese font.

Expected results:
3. 日本語 should be in ja font

Additional info:
For F9 Live at least seems Japanese font was preferred somehow
but that is bad for Chinese users of course.

Comment 1 Matthias Clasen 2008-07-09 03:28:28 UTC
Created attachment 311339 [details]
lang-tag.patch

Here is an untested patch.

Comment 2 Jens Petersen 2008-07-09 23:58:50 UTC
Thanks for the patch.

I tested it and it doesn't quite seem to have an affect.  I think the problem is
that normalized_language has the full locale name "ja_JP.UTF-8" but pango
only understand the lang name "ja" in its tags if I understand correctly.


Comment 3 Jens Petersen 2008-07-10 00:25:56 UTC
Created attachment 311430 [details]
Nihongo.png

Japanese for Japanese in the Japanese font.

Comment 4 Matthias Clasen 2008-07-10 05:09:01 UTC
Oh, I was applying the tag to the tooltip...



Comment 5 Matthias Clasen 2008-07-10 05:11:28 UTC
Created attachment 311445 [details]
better patch

Comment 6 Jens Petersen 2008-07-10 06:40:30 UTC
Thanks, Matthias!

That works well - I also note that now the language order coincides with lang
code which is better.

Comment 7 Matthias Clasen 2008-07-10 13:11:11 UTC
Oh, thats an artifact of sorting on the markup, which now has the lang tag as
first differentiating part:

<span lang="foo>Foo...


Note You need to log in before you can comment on or make changes to this bug.