Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451875 (epi-xul19-crash) - the last xulrunner crashes Epiphany
Summary: the last xulrunner crashes Epiphany
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: epi-xul19-crash
Product: Fedora
Classification: Fedora
Component: gtk+
Version: 9
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 451950 451997 452036 452094 452382 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-17 22:02 UTC by Carlo Raudino
Modified: 2018-04-11 18:59 UTC (History)
11 users (show)

Fixed In Version: epiphany-2.22.2-2.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-24 09:56:19 UTC


Attachments (Terms of Use)

Description Carlo Raudino 2008-06-17 22:02:19 UTC
Description of problem:
http://koji.fedoraproject.org/koji/buildinfo?buildID=52911
(for firefox 3) crashes epiphany..... epiphany doesn't start anymore.... crashes
at google homepage.....


Version-Release number of selected component (if applicable):
http://koji.fedoraproject.org/koji/buildinfo?buildID=52911

How reproducible:
install last xulrunner
run epiphany stable

  
Actual results:
downgrading to stable xulrunner, epiphany works

Comment 1 Joachim Frieben 2008-06-18 04:10:39 UTC
The same issue here on x86_64. After the crash, .xsession-errors contains
messages like: "** (epiphany:2933): WARNING **: EphyBrowser initialization
failed for 0x296c180".

Comment 2 Martin Stransky 2008-06-18 05:58:18 UTC
Epiphany needs to be rebuild against the new package. You can make it yourself
by "rpmbuild --rebuild epiphany-xxx.src.rpm" or wait to the official update.

Comment 3 Matthias Haase 2008-06-18 08:34:25 UTC
Rebuilding against new xulrunner fails. You have to rebuild
epiphany-2.22.1.1-3.fc10.src.rpm instead (contains build fix patch).

Comment 4 Scott J Henson 2008-06-18 15:17:05 UTC
I am experiencing the same problem and can confirm that a rebuild from rawhide
fixes the issue.

Comment 5 Martin Stransky 2008-06-18 18:10:19 UTC
It's here - http://koji.fedoraproject.org/koji/taskinfo?taskID=668974

Comment 6 Matěj Cepl 2008-06-18 20:30:03 UTC
*** Bug 451997 has been marked as a duplicate of this bug. ***

Comment 7 Pedro Matiello 2008-06-18 20:51:19 UTC
The linked package seems to be perfect, Martin. No more crashes here.

Comment 8 Matěj Cepl 2008-06-18 21:12:14 UTC
*** Bug 452036 has been marked as a duplicate of this bug. ***

Comment 9 Matěj Cepl 2008-06-19 12:07:40 UTC
*** Bug 451950 has been marked as a duplicate of this bug. ***

Comment 10 Matěj Cepl 2008-06-19 13:36:43 UTC
*** Bug 452094 has been marked as a duplicate of this bug. ***

Comment 11 Matěj Cepl 2008-06-21 19:26:56 UTC
*** Bug 452382 has been marked as a duplicate of this bug. ***

Comment 12 Tomasz Sterna 2008-06-21 23:05:27 UTC
[smoku@wing ~]$ rpm -q epiphany xulrunner
epiphany-2.22.2-2.fc9.i386
xulrunner-1.9-1.fc9.i386

Epiphany still crashes on almost every webpage.

Why is this Bug closed?

Comment 13 Tomasz Sterna 2008-06-21 23:14:36 UTC
See http://bugzilla.gnome.org/show_bug.cgi?id=538944

Comment 14 Alexey Torkhov 2008-06-22 14:59:31 UTC
(In reply to comment #12)
> Epiphany still crashes on almost every webpage.
I have the same versions of this packages and issue is resolved.

Comment 15 甘露(Gan Lu) 2008-06-23 04:29:48 UTC
To Tomasz Sterna:
Could you possibly use Epiphany with a clean profile, I have the same versions
and issue has been solved so far (3 days everyday using).

Comment 16 Tomasz Sterna 2008-06-23 07:32:33 UTC
1. How do I clean Epiphany profile?
2. It's not really a solution. I got used to my bookmarks and passwords. ;-)

Comment 17 Tomasz Sterna 2008-06-24 08:57:39 UTC
I tried rebuilding http://koji.fedoraproject.org/koji/rpminfo?rpmID=624204
myself, but it didn't help - Epiphany still crashes.

Comment 18 Tomasz Sterna 2008-06-24 09:08:56 UTC
I removed ~/.gconf/apps/epiphany and ~/.gnome2/epiphany, opened Epiphany in a
clean state and it just crashed on opening http://www.google.pl/

Comment 19 Tomasz Sterna 2008-06-24 09:12:06 UTC
See http://bugzilla.gnome.org/show_bug.cgi?id=539902 for the crash dump.

Comment 20 Matěj Cepl 2008-06-24 09:16:10 UTC
Looks interesting, but to my eyes it looks like a bug in GTK. Reassinging there.

Comment 21 Matěj Cepl 2008-06-24 09:22:18 UTC
Could you also switch off all Epiphany extensions and uninstall all plugins like
flash, etc.? Does it help?

Comment 22 Carlo Raudino 2008-06-24 09:56:19 UTC
Today I reinstalled epiphany and extensions after some days not being at home.

Now seems to work, so I think someone fixed the issue.

Thank you all

Comment 23 Tomasz Sterna 2008-06-24 10:00:49 UTC
With a clean profile it stopped crashing after I disabled "Select Stylesheet"
extension.

I tried disabling extensions before (with my previous profile) and it did not help.

I'll try merging a backup of my profile back and let you know of the effect.

Comment 24 Tomasz Sterna 2008-06-24 10:51:11 UTC
After restoring my profile (skipping the extensions gconf key) Epiphany now
works fine.


Note You need to log in before you can comment on or make changes to this bug.