Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451862 - Missing runtime dependency: rhino subpackages on rhino // Update request
Summary: Missing runtime dependency: rhino subpackages on rhino // Update request
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rhino
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Matt Wringe
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-17 20:03 UTC by Michel Alexandre Salim
Modified: 2008-06-17 20:21 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-17 20:21:34 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2008-06-17 20:03:07 UTC
Description of problem:
Rhino's subpackages do not depend on the main package; thus 'yum install
rhino-javadoc', for instance, does not pull in rhino.

Version-Release number of selected component (if applicable):
1.6-0.1.r5.1jpp.2

How reproducible:
Always

Steps to Reproduce:
1. Remove all rhino-related packages
2. yum install rhino-javadoc
  
Actual results:
rhino and rhino-javadoc should be installed

Expected results:
Only rhino-javadoc is installed

Additional info:
Rhino has not been updated since 2007 (F-9 build comes from F-7??). Time to
update it to 1.7R1 ?

Comment 1 Matt Wringe 2008-06-17 20:21:34 UTC
javadocs do not depend on the program, all the java packages should behave this
way. I don't see any reason why the documentation should have to also install
the package.

If you want to request an update of Rhino, please open a separate bug, don't
open multiple bugs in the same bug report.

Closing this javadoc dependency issues as NOT_A_BUG



Note You need to log in before you can comment on or make changes to this bug.