Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451831 - altivec detection breaks
Summary: altivec detection breaks
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pixman
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-17 17:43 UTC by David Woodhouse
Modified: 2008-06-19 17:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-19 17:37:02 UTC


Attachments (Terms of Use)
patch (deleted)
2008-06-17 17:43 UTC, David Woodhouse
no flags Details | Diff

Description David Woodhouse 2008-06-17 17:43:18 UTC
A bunch of builds in rawhide have got 'stuck' when running doxygen, and strace
showed that it was in an endless loop catching SIGILL...

[pid  1268] --- SIGILL (Illegal instruction) @ 0 (0) ---
[pid  1268] rt_sigreturn(0x4)           = 0
[pid  1268] --- SIGILL (Illegal instruction) @ 0 (0) ---
[pid  1268] rt_sigreturn(0x4)           = 0
[pid  1268] --- SIGILL (Illegal instruction) @ 0 (0) ---

Further investigation tracked it down to the Altivec detection in libpixman. We
don't need to play tricks with catching SIGILL to tell whether the host has
Altivec -- it's in the auxvec. Patch attached.

Comment 1 David Woodhouse 2008-06-17 17:43:19 UTC
Created attachment 309644 [details]
patch

Comment 2 Kevin Kofler 2008-06-18 01:08:56 UTC
Builds still fail in current dist-f10, when can we expect a fixed pixman in the 
buildroots?

Comment 3 David Woodhouse 2008-06-18 08:04:03 UTC
Er, really? I put libburn through yesterday after waiting for the new pixman to
hit the build repo, and it built fine. What package(s) are you still seeing
problems with?

Can you confirm the problem is the same? You can do this in the build system --
see https://www.redhat.com/archives/fedora-devel-list/2008-June/msg00995.html
for an example (don't forget to BR strace/expect/gdb or whatever you use).

Comment 4 Kevin Kofler 2008-06-18 08:06:40 UTC
kdepimlibs is still getting stuck: 
http://koji.fedoraproject.org/koji/buildinfo?buildID=52836

Comment 5 David Woodhouse 2008-06-18 09:17:21 UTC
Looks like it was still making progress when it got cancelled. A test build
(doing just the docs, to speed it up) completed successfully:
http://koji.fedoraproject.org/koji/taskinfo?taskID=667766

I'm doing another test build including the binaries now.

I wonder if the builder is just a little slow -- perhaps because it's got a
whole bunch of tasks chewing CPU by taking SIGILL and returning from it over and
over again... :)

Comment 6 David Woodhouse 2008-06-18 11:35:19 UTC
667953 build (dist-f10, devel:kdepimlibs-4_0_82-1_fc10) completed successfully


Comment 7 Adam Jackson 2008-06-19 17:37:02 UTC
Fixed pixman appears to be in the buildroot, closing.


Note You need to log in before you can comment on or make changes to this bug.