Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451811 - Last deleted/junked email not hidden
Summary: Last deleted/junked email not hidden
Keywords:
Status: CLOSED DUPLICATE of bug 450353
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-17 15:11 UTC by Mike Chambers
Modified: 2008-06-17 16:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-17 16:14:34 UTC


Attachments (Terms of Use)

Description Mike Chambers 2008-06-17 15:11:38 UTC
Description of problem:When you delete or junk the last email in a folder, it
stays there, not hidden.


Version-Release number of selected component (if applicable):

evolution-2.22.2-2.fc9.i386
evolution-bogofilter-2.22.2-2.fc9.i386
evolution-data-server-2.22.2-1.fc9.i386
evolution-help-2.22.2-2.fc9.i386
evolution-webcal-2.21.92-1.fc9.i386


How reproducible:Always


Steps to Reproduce:
1.Make sure View/Hide deleted messages is checked.
2.Select and delete or junk last email or select all emails in folder and
delete/junk them all
  
Actual results:The email is deleted or junked, but isn't hidden or moved to the
junk folder until you click on another email folder and then back to the
original folder.


Expected results:The email should be hidden or moved to junk folder even if last
one in the folder.


Additional info:If the email is NOT the last one, it will get hidden or moved to
the junk email folder as appropriate.

Comment 1 Milan Crha 2008-06-17 16:14:34 UTC
Thanks for reporting this. We moved this upstream together with the duplicate
bug, and the upstream bug contains a patch, which will be included in next release.

*** This bug has been marked as a duplicate of 450353 ***


Note You need to log in before you can comment on or make changes to this bug.