Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4518 - [PATCH] Pump forgets stuff after first lease renewal.
Summary: [PATCH] Pump forgets stuff after first lease renewal.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump
Version: 6.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-14 05:29 UTC by dunham
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-28 14:48:05 UTC


Attachments (Terms of Use)

Description dunham 1999-08-14 05:29:43 UTC
There is a typo in the parseLease function, clearing out
everything but the lease option in pump, rather than
clearing out just the lease option, i.e.

line 885 of pump.c, which reads:

    intf->set &= INTFINFO_HAS_LEASE;

should be:

    intf->set &= ~INTFINFO_HAS_LEASE;

(note the negation.)

To reproduce on a machine that is not currently running
pump, run "pump" to obtain a lease, then run
"pump -s", observe "Domain" and other extra options.
Run "pump -R" to force renewal. Run "pump -s" again and
see that "Domain" has disappeared.

Comment 1 Bill Nottingham 1999-08-14 19:39:59 UTC
Have you tried the errata pump release?

Comment 2 dunham 1999-08-15 04:23:59 UTC
The latest one I had looked at was 0.6.7, apparently 0.7.0 is in the
the updates directory but not on the errate web page.

Either way, the problem is still there in 0.7.0.  I will update the
Debian package to 0.7.0 and add my fix.  In addition to looking into
this problem, you might want to make sure 0.7.0 shows up on the
errata page.
page.

Comment 3 Erik Troan 1999-10-28 14:48:59 UTC
Thanks for the patch!


Note You need to log in before you can comment on or make changes to this bug.