Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451784 - libvirt 0.4.3 doesn't always clean up after itself
Summary: libvirt 0.4.3 doesn't always clean up after itself
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 451709
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-17 12:21 UTC by Chris Lalancette
Modified: 2008-07-01 05:30 UTC (History)
2 users (show)

Fixed In Version: 0.4.4-1.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-01 05:30:17 UTC


Attachments (Terms of Use)

Description Chris Lalancette 2008-06-17 12:21:52 UTC
Description of problem:
As a corollary of BZ 451709, when libvirtd fails to start domains because of the
bug there, it also fails to clean up after itself.  In particular, it leaves a
"vnet?" device visible and connected to virbr0, even though there is no domain.
 This further causes problems when rebooting the kernel, since you then get
messages "kernel: waiting for netdev vnet0 to become free" infinitely.  You also
cannot kill the libvirtd daemon.

Comment 1 Chris Lalancette 2008-06-19 09:09:16 UTC
Hm.  Weird.  I can't seem to reproduce the "can't kill libvirtd" problem at the
moment (after a reboot of the host machine).  However, the "doesn't cleanup
vnet?" is still a problem.

Chris Lalancette

Comment 2 Chris Lalancette 2008-06-19 10:08:15 UTC
This one is actually closely related to BZ 451709, which I now have a patch for.
 I'm going to close it as a duplicate.

Chris Lalancette

*** This bug has been marked as a duplicate of 451709 ***

Comment 3 Fedora Update System 2008-06-25 09:27:16 UTC
libvirt-0.4.4-1.fc9 has been submitted as an update for Fedora 9

Comment 4 Fedora Update System 2008-07-01 05:30:10 UTC
libvirt-0.4.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.