Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451767 - OpenOffice Print defaults to Letter not CUPS default
Summary: OpenOffice Print defaults to Letter not CUPS default
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 458833
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-17 09:36 UTC by Philip Frampton
Modified: 2009-06-10 07:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-06-10 07:24:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 92819 None None None Never

Description Philip Frampton 2008-06-17 09:36:45 UTC
Description of problem:
Openoffice doesn't default to paper size set by Cups.

Version-Release number of selected component (if applicable):
2.4

How reproducible:
Install a printer (I have HP F4100, Brother 2600N, and CUPS-PDF), set default
papersize to A4. Load OpenOffice (UK / GB settings). Page defaults to A4 but
when you do File->Print all printer default to US Letter or Letter page size.


Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
Default print size is Letter

Expected results:
Default print size is CUPS default (A4 in my case)

Additional info:

Planner (the only other gnome app I have that has a page size setting in a print
dialog) defaults to A4 - the Cups default.

Also, I have tried changing the default printer page setting in "spadmin" but
the new value is not remembered.

Comment 1 Caolan McNamara 2008-06-17 09:53:54 UTC
Is this paper size as shown under "properties" tab in the file->print dialog ?

Comment 2 Philip Frampton 2008-06-17 10:38:09 UTC
Yes. And now that I have got cups-pdf working (SE Linux problem) I can see that
even though the Properties said Letter the PDF it printed was A4.

Philip

Comment 3 Caolan McNamara 2008-06-17 10:49:06 UTC
yeah, that controls very little. Where it kicks in is when the "page style" is
not used for the actual paper it goes onto, which in writer can only arise for
"N pages in 1", where multiple pages are printed on one sheet of paper.

We should make it come from the correct defaulted paper size, but its more of a
fringe feature than it looks initially.

Comment 4 Caolan McNamara 2008-06-20 16:16:23 UTC
Can you check two things for me...

a) the output of "locale"
b) the output of "paperconf" (even if the answer is "command not found")

Comment 5 Philip Frampton 2008-06-23 13:19:35 UTC
$ locale
LANG=en_GB.utf8
LC_CTYPE="en_GB.utf8"
LC_NUMERIC="en_GB.utf8"
LC_TIME="en_GB.utf8"
LC_COLLATE="en_GB.utf8"
LC_MONETARY="en_GB.utf8"
LC_MESSAGES="en_GB.utf8"
LC_PAPER="en_GB.utf8"
LC_NAME="en_GB.utf8"
LC_ADDRESS="en_GB.utf8"
LC_TELEPHONE="en_GB.utf8"
LC_MEASUREMENT="en_GB.utf8"
LC_IDENTIFICATION="en_GB.utf8"
LC_ALL=

$ paperconf
letter

$ cat /etc/papersize
# Simply write the paper name. See papersize(5) for possible values

(ie empty)


Hope this helps.

Philip

Comment 6 Caolan McNamara 2008-06-23 21:13:53 UTC
Yeah, that helps. We need to fix a number of things as a distro with regards to
default pages sizes, there are a *lot* of things that could do with fixing. But
the very first problem in your particular story is the damnable paperconf which
as you see defaults to *letter*, which is the most terrible default to use. I'd
like to see paperconf do something along the lines of the patch I submitted as
http://article.gmane.org/gmane.linux.debian.devel.bugs.general/436693 to the
paperconf upstream to pick a better way to choose a default if unconfigured

I'd be interested in what packages you have installed that caused paperconf to
get installed, i.e. maybe the output of...

rpm -q --whatrequires paperconf

Comment 7 Philip Frampton 2008-06-24 07:14:07 UTC
/usr/bin/paperconf is in libpaper package

libpaper package is required by html2ps package

html2ps package is required by a2ps package

a2ps is not required by anything (well that I have installed). So I had a look
through yum groupinfo and found that a2ps is a default package in "Printing
Support" group. I've now removed a2ps (html2ps and libpaper) and verified that
OpenOffice now defaults to the correct page size (A4) in the print dialogue.

Comment 8 Tim Waugh 2008-07-02 09:14:28 UTC
FWIW, even though File->Print->Properties->Paper Size lists 'Letter' for me in
en_GB.UTF-8, the actual print output is A4 for a newly-created document.

Comment 9 Caolan McNamara 2008-07-02 11:43:08 UTC
Yeah, see #3 it controls very little actually. It should only matter where there
is no page style to override it, e.g. printing from oomath for example

I'll write a little document when I get the chance about where the sizes come
from and what the affect and we can walk through it on fedora-devel

Comment 10 Riccardo Rencinai 2008-07-07 15:17:17 UTC
I have to report the same problem which has been, in fact, resolved through the
/etc/papersize setting. It's my experience that this problem is not limited to
the papersize value. Other important settings like Duplex and Color suffer the
same fate. The openoffice print requester simply doesn't hold the CUPS settings.
Of course I have tried with the latest upgrades (as of now) and with a new
document to avoid retaining other settings. 

Using other apps (ie, Firefox, Evince) the problem doesn't show up, so this
should be an OpenOffice fault.


Comment 11 Caolan McNamara 2008-07-31 14:18:26 UTC
Documented the page stuff at
http://wiki.services.openoffice.org/wiki/DefaultPaperSize

Comment 12 Caolan McNamara 2008-08-26 13:51:13 UTC
The substantive original part of this has now been fixed in fedora "libpaper", i.e. bug 458833

I want to hold onto this to until I get the upstream http://qa.openoffice.org/issues/show_bug.cgi?id=92819 into OpenOffice.org so as to be consistent with the *document* paper size and the default *printer* paper size (http://wiki.services.openoffice.org/wiki/DefaultPaperSize) and maybe do a Fedora 11 feature for this or something, as there's quite a bit of contradiction around what countries use what as a default.

And afterwards I'll take on board the suggestion to have the printer dialog store the previous used setting somewhat like evince does.

Comment 13 Tim Waugh 2008-08-26 14:01:14 UTC
Having a "default printer paper size" that does not come from the printer queue's PPD is just making things up.

The default paper size for a particular printer comes from its PPD -- anything else is irrelevant.

Comment 14 Caolan McNamara 2008-08-26 14:07:28 UTC
Yes, it's making it up. But it has to be this way because there can be no printers at all, and if there are printers then querying for the default paper like was done way in the past can lag OOo to a shocking degree with network printers. Upstream behaviour was changed away from that ages ago, except for calc under some scenarios, and that's one of the most common "calc is f*cked up and won't start for ages" complaints. Given that we (and gtk, etc.) are really hanging "default paper" off locale information, we should at least be consistent about how we do it.

Comment 15 Bug Zapper 2008-11-26 02:26:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 16 Sergey Yanovich 2009-01-20 00:23:07 UTC
In fact, the whole paper issue is a bit annoying. /etc/papersize settles VCL default paper size for good, but there is still a problem:

Application default paper size is taken from "LC_ALL, LC_CTYPE, LANG". Is there any good reason why it is not LC_PAPER??? If no, the fix looks like one-liner.

Comment 17 Caolan McNamara 2009-01-20 08:57:25 UTC
Application paper-sizes will come from LC_PAPER in the proposed patch and work logged upstream (which has to hold off after the current feature freeze to make its way in). Its not a one-liner as it currently stands as the application default paper size comes through an intermediate set of stuff which is based indeed eventually on LC_etc but its a single OOo setting which is used for a whole set of other stuff where LC_PAPER is definitely the wrong setting.

Comment 19 Caolan McNamara 2009-05-29 14:27:31 UTC
implementation complete, submitted workspace to upstream QA. Checked in to rawhide/F-12, will be in >= 3.1.1-12.2

Comment 20 Bug Zapper 2009-06-09 09:37:21 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 21 Caolan McNamara 2009-06-10 07:24:55 UTC
All set up the way I want it now in 3.1.1-12.2.fc12 for rawhide


Note You need to log in before you can comment on or make changes to this bug.