Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451750 - tclConfig.sh is no longer found in auto_path
Summary: tclConfig.sh is no longer found in auto_path
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tcl
Version: 9
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-17 03:04 UTC by Tom Lane
Modified: 2013-07-03 03:18 UTC (History)
2 users (show)

Fixed In Version: tcl-8.5.2-3.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-02 08:10:03 UTC


Attachments (Terms of Use)

Description Tom Lane 2008-06-17 03:04:30 UTC
Description of problem:
In previous tcl releases, tclConfig.sh could be found by searching the directories named in $auto_path.
In 8.5 this is no longer the case.  This breaks autoconfiguration of PostgreSQL, and likely some other packages.

Version-Release number of selected component (if applicable):
tcl-devel-8.5.1-5

How reproducible:
100%

Steps to Reproduce:
1. rpm -ql tcl-devel | grep tclConfig
/usr/lib64/tclConfig.sh
2. $ tclsh
% puts $auto_path
/usr/share/tcl8.5 /usr/lib64/tcl8.5 /usr/lib64/tk8.5 /usr/lib/tcl8.5 /usr/lib/tk8.5

Actual results:
tclConfig.sh is not in any of the mentioned directories.

Expected results:
8.4 had auto_path equal to
/usr/share/tcl8.4 /usr/share /usr/lib /usr/lib64 /usr/lib64/tcl8.4
so it was possible to find tclConfig.sh in the path.

An alternative solution would be to leave auto_path as-is and put tclConfig.sh into usr/lib64/tcl8.5.

Additional info:
It is a step forward that 8.5 lists /usr/lib64 before /usr/lib, because that
gives us a shot at working when both bit-sizes are installed.  (I trust the
i386 package doesn't list /usr/lib64.)  Please don't break that.

Comment 1 Marcela Mašláňová 2008-06-24 07:54:50 UTC
I followed the guidelines here https://fedoraproject.org/wiki/Packaging/Tcl

I removed /usr/lib from paths, because looking for modules took ages. The
solution could be symlink tclConfig.sh into /usr/lib{64}/tcl8.5 or fix it in
dependent packages.

Comment 2 Tom Lane 2008-06-24 13:57:36 UTC
Moving or symlinking tclConfig.sh into that directory would be fine with me.

Comment 3 Marcela Mašláňová 2008-06-25 14:06:10 UTC
Ok, I moved tclConfig.sh into /usr/lib/tcl8.5. It looks like correct place for
bash scripts in libdir.

Comment 4 Fedora Update System 2008-06-26 06:26:29 UTC
tcl-8.5.2-1.fc9 has been submitted as an update for Fedora 9

Comment 5 Fedora Update System 2008-06-28 22:16:23 UTC
tcl-8.5.2-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Jindrich Novy 2008-07-02 07:33:28 UTC
Please don't *move* tclConfig.sh to /usr/lib{64}/tcl8.5 without adding symlink
to it in /usr/lib{64}/. This breaks autoconfiguration of db4 and other stuff
dependent on tcl. Please add the symlink to /usr/lib{64} as proposed in comment #1.

Comment 7 Marcela Mašláňová 2008-07-02 08:10:03 UTC
Ok, updated also in rawhide. The symlink into /usr/lib is possibly the smallest
bad thing to do.


Note You need to log in before you can comment on or make changes to this bug.