Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451734 - Grub Portion of UEFI Support
Summary: Grub Portion of UEFI Support
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: grub
Version: 5.5
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: beta
: 5.5
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-17 01:17 UTC by Larry Troan
Modified: 2016-04-18 09:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-24 11:36:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Larry Troan 2008-06-17 01:17:26 UTC
Description of problem:

This feature request is to track the grub portion of UEFI support.

From bug 253295 (kernel portion)

Short Description: Request full support for UEFI for i386 and x86_64 archs. 
Requires UEFI extensions to lilo/grub boot loaders. Also expect support EFI 
Variables in NVRAM exported to the OS, EFI runtime services. It appears most 
of the development for i386 is complete, but needs to be verified. x86_64 
support is being developed by Intel and needs to be submitted upstream. ia64 
has supported EFI from the beginning. 
Architecture: x86  x86_64

Comment 2 Larry Troan 2008-06-17 01:40:32 UTC
Summary:
* Bug 253295: UEFI support (kernel)
* Bug 451737: Bootloader Portion of UEFI Support
* Bug 451734: Grub Portion of UEFI Support

Comment 4 Larry Troan 2008-12-12 16:14:20 UTC
*** Bug 475687 has been marked as a duplicate of this bug. ***

Comment 6 Larry Troan 2009-08-24 11:36:46 UTC
On Fri, 2009-08-14 at 15:40 -0400, Denise Dumas wrote:
> Guys, we are not going to be able to do this in rhel5.  Even [the 
> suggested] backup [of] "just port grub" doesn't work.
> 
> The different hard disk formats and boot configuration for the two 
> firmware types mean that the OS must boot from the firmware that was 
> used for the installation. RHEL6 with UEFI support cannot boot from
> BIOS firmware and vice versa. (Windows also has this limitation).
> 
> Denise


Note You need to log in before you can comment on or make changes to this bug.