Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451729 - "package-cleanup --cleandupes" doesn't appear to clean duplicate kernel-headers packages
Summary: "package-cleanup --cleandupes" doesn't appear to clean duplicate kernel-heade...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-17 00:01 UTC by Tom London
Modified: 2014-01-21 06:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-08 13:02:18 UTC


Attachments (Terms of Use)

Description Tom London 2008-06-17 00:01:08 UTC
Description of problem:
I had the situatation where I had to cleanup lots of duped packages, but
package-cleanup didn't clean up duplicate kernel-headers packages.

Version-Release number of selected component (if applicable):
yum-utils-1.1.14-4.fc10.noarch

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jan Hutař 2008-09-08 12:37:39 UTC
Hello,
same for me on F8 with yum-utils-1.1.14-4.fc8 - maybe it is intentional?:

# package-cleanup --dupes
Setting up yum
abcde-2.3.99.6-4.fc8.noarch
abcde-2.3.99.6-6.noarch
# rpm -q abcde kernel-headers
abcde-2.3.99.6-6
abcde-2.3.99.6-4.fc8
kernel-headers-2.6.23.1-42.fc8
kernel-headers-2.6.25.14-69.fc8

Comment 2 seth vidal 2008-09-08 13:02:18 UTC
anything starting with kernel is intentionally ignored.

Comment 3 Tom London 2008-09-08 13:24:10 UTC
But does that make sense?

Newer packages like kernel-headers and kernel-firmware are updated, not installed, so there shouldn't be duplicate versions of them.

Wouldn't it make sense for package-cleanup to only ignore dupes on packages that it "installs only"?


Note You need to log in before you can comment on or make changes to this bug.