Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451723 - kernel 2.6.25.6-55.fc9.i686, driver iwl4965 freezes system
Summary: kernel 2.6.25.6-55.fc9.i686, driver iwl4965 freezes system
Keywords:
Status: CLOSED DUPLICATE of bug 451395
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 451489 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 21:33 UTC by Johan Vromans
Modified: 2009-02-14 20:36 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 19:01:38 UTC


Attachments (Terms of Use)

Description Johan Vromans 2008-06-16 21:33:28 UTC
Description of problem:

On a Toshiba Satellite A200-237, using the iwl4965 wireless driver that comes
with the 2.6.25.6-55.fc9.i686 kernel freezes the system.

Version-Release number of selected component (if applicable):

kernel 2.6.25.6-55.fc9.i686 as available from the Fedora updates repository.

How reproducible:

Always.


Steps to Reproduce:
1. Boot the notebook.
2. Activate the wireless.
3. While the NetworkManager tries to setup the connection, the system freezes.
The CapsLock led flashes.

Additional info:

No syslog messages are given.

Wireless works with kernel 2.6.25.4-30.fc9.i686.
The wireless connection is with an AP that is WEP protected. The AP codes are
available in the keyring.

Comment 1 Chuck Ebbert 2008-06-17 02:37:03 UTC
I believe this is fixed in -57 and up?

Comment 2 Johan Vromans 2008-06-17 13:12:55 UTC
I'll check when 57 or up becomes available. It is not on updates/-testing yet.

Comment 3 Dax Kelson 2008-06-17 23:41:42 UTC
Myself and two other co-workers with T61p laptops have this same freeze/lockup
problem that started with 2.6.25.6-55 problem. Bug 451395 is likely a dup of
this bug.

Comment 4 Trond Danielsen 2008-06-18 05:47:42 UTC
I can confirm this bug on x86_64. Laptop is T61p with Nvidia gfx (xorg drv).
Kernel panic occur just after I log into gnome (nm-applet starts?). If I boot
with the hw rf killswitch turned of, the problem is no longer present.

Comment 5 Tore H. Larsen 2008-06-18 23:15:06 UTC
I also can confirm this. Reverted to previous kernel. Laptop is T61p.

Comment 6 Julien Dambron 2008-06-19 05:24:14 UTC
I can confirm this problem on X86_64 with KDE.

Comment 7 Mike Hanby 2008-06-20 20:13:09 UTC
I can confirm this with i686 version running on a Dell XPS m1330 notebook with
the Intel 802.11n wifi card. Reverting to previous kernel I can successfully
login to the gnome desktop.

Comment 8 Adam D. Ligas 2008-06-21 06:13:40 UTC
Confirmed on T61 (iwl4965) running X86_64.  The machine freezes when the second
"dot" in NetworkManager lights up.  Caps lock flashes, machine totally frozen. 
Reverting to previous kernel appears to work around the issue.

Bug does *NOT* occur at my home where I run Wireless-G with WPA2 security.

Bug *DOES* occur at my girlfriend's house where she runs Wireless-B with WEP-128.

Comment 9 Tore H. Larsen 2008-06-21 08:08:01 UTC
I can confirm that it occurs on WEP-40/128 HEX on 802.11g.

Comment 10 Ian 2008-06-22 19:17:31 UTC
I am having the same problem on 2.6.25.6-55.fc9.x86_64 with an Intel 4965 AGN
wifi card. I can get my computer to boot by eater using an older kernel version
or by booting with wifi off, but if I turn it on it will freeze.

Comment 11 Ian 2008-06-22 21:18:30 UTC
This bug seems to be the same as https://bugzilla.redhat.com/show_bug.cgi?id=451510

Comment 12 John W. Linville 2008-06-23 19:01:38 UTC

*** This bug has been marked as a duplicate of 451395 ***

Comment 13 Johan Vromans 2008-07-03 19:58:11 UTC
I can confirm that bug 451723 no longer seem to occur in kernel 2.6.25.9-76.

Comment 14 Dan Williams 2009-02-14 20:36:55 UTC
*** Bug 451489 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.