Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451710 - Problem in initscript
Summary: Problem in initscript
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: radvd
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jiri Skala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 20:06 UTC by mail@romal.de
Modified: 2014-11-09 22:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 14:53:44 UTC


Attachments (Terms of Use)

Description mail@romal.de 2008-06-16 20:06:32 UTC
Description of problem:

The initscript fails.

Start and reload do never produce a "started"
Stop does always fail.

The daemon is running, when manually started:

[root@nass init.d]# radvd -d 4
^C[root@nass init.d]# /etc/init.d/radvd start
[root@nass init.d]# /etc/init.d/radvd restart
radvd beenden:                                             [FEHLGESCHLAGEN]
[root@nass init.d]# /etc/init.d/radvd reload
radvd neu laden:                                           [FEHLGESCHLAGEN]
[root@nass init.d]# radvd -d 4 -u radvd

The config-file is ok, ... I get dumps via radvdump and other ipv6-hosts get
their network. But all this does only work, when I start the daemon manually.

Version-Release number of selected component (if applicable):

[root@nass init.d]# rpm --query radvd
radvd-1.1-2.fc9.i386
[root@nass init.d]# 

How reproducible:

Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jiri Skala 2008-06-23 14:53:44 UTC
Setting statuses restart, reload and stop fails because the radvd is not
started! The IPv6 networking and forwarding have to be enabled for successful
starting:

/etc/sysconfig/network have to contain following lines:
NETWORKING_IPV6=yes
IPV6FORWARDING=yes

If the IPv6 networking is not enabled the LSB compliant script have to return
correspondent exit code. The current release is unfortunately not LSB compliant!
This bug is fixed in release radvd-1.1-4.fc10. There will be displayed an error
message now if the IPv6 networking isn't enabled.




Note You need to log in before you can comment on or make changes to this bug.