Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451702 - Admin Server fails on F9 due to NSS 3.12 libs moved to /lib
Summary: Admin Server fails on F9 due to NSS 3.12 libs moved to /lib
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Install/Uninstall
Version: 1.1.1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks: FDS112
TreeView+ depends on / blocked
 
Reported: 2008-06-16 19:03 UTC by Mark Smith
Modified: 2015-12-07 16:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-07 16:37:08 UTC


Attachments (Terms of Use)
diffs (deleted)
2008-08-29 01:39 UTC, Rich Megginson
no flags Details | Diff
real diffs (deleted)
2008-08-29 01:58 UTC, Rich Megginson
no flags Details | Diff
cvs commit log (deleted)
2008-08-29 02:15 UTC, Rich Megginson
no flags Details

Description Mark Smith 2008-06-16 19:03:36 UTC
Description of problem: Incorrect path to object libssl3.so doing installation.


Version-Release number of selected component (if applicable): FDS 1.1.1


How reproducible: Incorrect object path


Steps to Reproduce:
1. Reinstall FDS 1.1.1 on F9
2. 
3.
  
Actual results:
[08/06/13:11:21:26] - [Setup] Info output: ERROR: ld.so: object
'/usr/lib/libssl3.so' from LD_PRELOAD cannot be preloaded: ignored.
[08/06/13:11:21:26] - [Setup] Info output: ERROR: ld.so: object
'/usr/lib/libssl3.so' from LD_PRELOAD cannot be preloaded: ignored.
[08/06/13:11:21:26] - [Setup] Info output: ERROR: ld.so: object
'/usr/lib/libssl3.so' from LD_PRELOAD cannot be preloaded: ignored.

Expected results:


Additional info: To fix the problem, Modify the path in /usr/sbin/start-ds-admin
script on line 44 to point to the correct directory; which is /lib/ and not
/usr/lib/. Then you have to start the (dirsrv-admin) by running the script
/usr/sbin/start-ds-admin because service dirsrv-admin start command fails with
the following error message: [root@sun ~]# service dirsrv-admin start
Starting dirsrv-admin:
runcon: invalid context: unconfined_u:system_r:unconfined_t:s0: Invalid argument
                                                           [FAILED]

Comment 1 Rich Megginson 2008-06-23 19:26:52 UTC
NSS 3.12 has moved the runtime libs from /usr/lib to /lib (and probably /lib64
on 64-bit).  The start-ds-admin script needs to be smarter about where to look
for these when doing the LD_PRELOAD (and we need to see if we still need to
LD_PRELOAD ssl3.so - maybe we don't need to do that anymore on f9 and this
problem goes away?).

Comment 2 Rich Megginson 2008-08-29 01:39:06 UTC
Created attachment 315317 [details]
diffs

Comment 3 Rich Megginson 2008-08-29 01:58:48 UTC
Created attachment 315318 [details]
real diffs

Comment 4 Rich Megginson 2008-08-29 02:15:33 UTC
Created attachment 315319 [details]
cvs commit log

Reviewed by: nkinder (Thanks!)
Fix Description: The problem is that nss-devel puts libssl3.so in libdir at build time, but at runtime there is only nss which now uses /lib|/lib64.  So the build time nsslibdir is not the same as the runtime nsslibdir.  It looks as though the preload of ssl3 is not needed with f9 and/or nss 3.12.  So we just look for libssl3.so in the $libdir, if not found, we just skip it, and assume it's nss 3.12 and/or f9 and it is not needed.
Platforms tested: Fedora 8, Fedora 9
Flag Day: no
Doc impact: no

Comment 5 Orion Poplawski 2008-09-15 16:06:15 UTC
I can't build fedora-ds-admin src.rpm from CVS devel:

rpmbuild --define "_sourcedir /export/home/orion/fedora/fedora-ds-admin/devel" --define "_specdir /export/home/orion/fedora/fedora-ds-admin/devel" --define "_builddir /export/home/orion/fedora/fedora-ds-admin/devel" --define "_srcrpmdir /export/home/orion/fedora/fedora-ds-admin/devel" --define "_rpmdir /export/home/orion/fedora/fedora-ds-admin/devel" --define "dist.fc10" --define "fedora 10" --define "fc10 1" --nodeps -bs fedora-ds-admin.spec
error: File /export/home/orion/fedora/fedora-ds-admin/devel/bug451702.patch: No such file or directory
make: *** [srpm] Error 1

Also, looks like you have both 1.1.5 and 1.1.6 listed in sources.

Comment 6 Rich Megginson 2008-09-15 17:39:16 UTC
Sorry about that.  I removed the patch for F-9 - I guess I forgot to do that for devel.

Checking in fedora-ds-admin.spec;
/cvs/extras/rpms/fedora-ds-admin/devel/fedora-ds-admin.spec,v  <--  fedora-ds-admin.spec
new revision: 1.5; previous revision: 1.4
done

Comment 7 Orion Poplawski 2010-03-10 22:40:22 UTC
This seems really old and probably should be closed.


Note You need to log in before you can comment on or make changes to this bug.