Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451701 - Poor bit rate with rt61pci based wlan card
Summary: Poor bit rate with rt61pci based wlan card
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 18:59 UTC by Mats Ljunggren
Modified: 2008-07-28 15:05 UTC (History)
1 user (show)

Fixed In Version: 2.6.25.10-86.fc9.x86_64
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-28 15:05:56 UTC


Attachments (Terms of Use)

Description Mats Ljunggren 2008-06-16 18:59:50 UTC
Description of problem:
I get very poor bit rate between my RaLink RT2561/RT61 rev B 802.11g wlan card and wlan router 
(only about 4 meters between them). With kernel 2.6.25.6-55.fc9.x86_64 I only get a bit rate of 2 
Mb/s. With previous kernels (e.g. 2.6.25.4-30.fc9.x86_64) I get 54 Mb/s.

Version-Release number of selected component (if applicable):
kernel-2.6.25.6-55.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Bit rate of only 2 Mb/s

Expected results:
Higher bit rate, mostly 54 Mb/s

Additional info:
dmesg output:
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:19:5b:e5:2e:f0
wlan0: RX authentication from 00:19:5b:e5:2e:f0 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:19:5b:e5:2e:f0
wlan0: authentication frame received from 00:19:5b:e5:2e:f0, but not in authenti
cate state - ignored
wlan0: RX AssocResp from 00:19:5b:e5:2e:f0 (capab=0x421 status=0 aid=2)
wlan0: associated
wlan0: switched to short barker preamble (BSSID=00:19:5b:e5:2e:f0)
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:0f:66:c7:a4:ef
wlan0: RX authentication from 00:0f:66:c7:a4:ef (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:0f:66:c7:a4:ef
wlan0: RX AssocResp from 00:0f:66:c7:a4:ef (capab=0x411 status=0 aid=1)
wlan0: associated
wlan0: switched to long barker preamble (BSSID=00:0f:66:c7:a4:ef)
wlan0: No ProbeResp from current AP 00:0f:66:c7:a4:ef - assume out of range
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:0f:66:c7:a4:ef
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:0f:66:c7:a4:ef
wlan0: RX authentication from 00:0f:66:c7:a4:ef (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:0f:66:c7:a4:ef
wlan0: authentication frame received from 00:0f:66:c7:a4:ef, but not in authenti
cate state - ignored
wlan0: RX ReassocResp from 00:0f:66:c7:a4:ef (capab=0x411 status=0 aid=1)
wlan0: associated

Comment 1 Mats Ljunggren 2008-07-22 15:26:05 UTC
With kernel 2.6.25.10-86.fc9.x86_64 the problem is gone. Bit rate is back at 54 Mb/s again.

Comment 2 John W. Linville 2008-07-28 15:05:56 UTC
Thanks for the report!


Note You need to log in before you can comment on or make changes to this bug.