Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451689 - Traceback NameError: global name 'bootProto' is not defined
Summary: Traceback NameError: global name 'bootProto' is not defined
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 451731 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 18:14 UTC by Orion Poplawski
Modified: 2008-06-17 00:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-16 18:21:43 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2008-06-16 18:14:30 UTC
Description of problem:

Doing PXE kickstart http install with today's rawhide.

Traceback (most recent call last):
File "/usr/bin/anaconda", line 954, in <module>
                    kickstart.processKickstartFile(anaconda, opts.ksfile)
File "/usr/lib/anaconda/kickstart.py", line 956, in processKickstartFile
                                                            
ksparser.readKickstart(file)
                                                                               
           File "/usr/lib/python2.5/site-packages/pykickstart/parser.py", line
709, in readKickstart
                 self._stateMachine (lambda: fh.readline())
File "/usr/lib/python2.5/site-packages/pykickstart/parser.py", line 584, in
_stateMachine
                                                   self.handleCommand(lineno, args)
                                                                               
     File "/usr/lib/anaconda/kickstart.py", line 908, in handleCommand
                                                               
KickstartParser.handleCommand(self, lineno, args)
File "/usr/lib/python2.5/site-packages/pykickstart/parser.py", line 429, in
handleCommand
                            self.handler.dispatcher(args, lineno)
File "/usr/lib/python2.5/site-packages/pykickstart/base.py", line 328, in dispatcher
                                                                
self.commands[cmd].parse(args[1:])
           File "/usr/lib/anaconda/kickstart.py", line 385, in parse
                                                                        if
(devices and bootProto):
NameError: global name 'bootProto' is not defined

I have:

network --bootproto=dhcp

in my ks file.

Comment 1 Chris Lumens 2008-06-16 18:21:43 UTC
This will be fixed in the next build of anaconda.  Thanks for the bug report.

Comment 2 Chris Lumens 2008-06-17 00:44:11 UTC
*** Bug 451731 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.