Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451683 - Failed to restore screen after resume if xrandr in use
Summary: Failed to restore screen after resume if xrandr in use
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pm-utils
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 17:40 UTC by pasqual milvaques
Modified: 2015-03-05 01:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-06 14:47:13 UTC


Attachments (Terms of Use)

Description pasqual milvaques 2008-06-16 17:40:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
In my laptop I use xrandr to disable the laptop screen and use an external vga monitor. In this situation I hibernate the machine and after resume the screen is corrupted, I kill X with control+alt+del and the gdm login appears correctly and I can work correctly

Version-Release number of selected component (if applicable):
pm-utils-1.1.0-7.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1.use xrandr to disable latop screen and use external vga monitor in enhaced resolution:
xrandr --output VGA-0 --mode 1280x1024 --rate 75.0 --same-as LVDS
xrandr --output LVDS --off
2.hibernate the machine
3.resume

Actual Results:
the screen is corrupted, the pointer is a kind of square and is impossible to read something

Expected Results:
the screen as was when I hibernated the machine

Additional info:
[root@ ~]# lspci  | grep -i radeon
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon XPRESS 200M 5955 (PCIE)
[root@ ~]# 

I use the radeon open source driver, the card is a integrated Radeon XPRESS 200M
Compiz is enabled

Comment 1 Till Maas 2008-06-16 21:46:12 UTC
Can you please report the output of:

 lshal | egrep
"(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"

Comment 2 pasqual milvaques 2008-06-16 22:16:38 UTC
here it is:
[zzzzzz@ ~]$ lshal | egrep
"(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"
  system.firmware.version = 'F.27'  (string)
  system.hardware.product = 'Presario M2000 (EK815EA#ABE)'  (string)
  system.hardware.vendor = 'Hewlett-Packard'  (string)
  system.hardware.version = 'Rev 1'  (string)
[zzzzzz@ ~]$ 


Comment 3 pasqual milvaques 2008-10-05 17:30:14 UTC
it seems that with the xorg server upgrade to version 1.5 the problem has disappeared. I currently have this version:
xorg-x11-server-Xorg-1.5.0-2.fc9.x86_64

and with it the problem is not reproducing any more

best regards

Comment 4 Phil Knirsch 2008-10-06 14:47:13 UTC
Closing it as fixed in rawhide then. Feel free to reopen if the problem reappears.

Regards, Phil


Note You need to log in before you can comment on or make changes to this bug.