Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451682 - automount segfault on SIGHUP after negative lookups
Summary: automount segfault on SIGHUP after negative lookups
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs
Version: 4.6
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jeff Moyer
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On: 450844
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 17:38 UTC by James G. Brown III
Modified: 2014-12-01 23:06 UTC (History)
3 users (show)

Fixed In Version: RHBA-2008-0564
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-01 13:05:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Handle negative map entries in the cache code. (deleted)
2008-06-16 17:43 UTC, James G. Brown III
no flags Details | Diff
Fix the previous patch to not loop infinitely upon finding a negative mapent. (deleted)
2008-06-19 17:10 UTC, Jeff Moyer
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0564 normal SHIPPED_LIVE autofs bug fix update 2008-07-01 13:05:09 UTC

Comment 1 James G. Brown III 2008-06-16 17:43:19 UTC
Created attachment 309520 [details]
Handle negative map entries in the cache code.

Comment 4 David Mair 2008-06-16 23:53:43 UTC
You can't request EUS flags because only certain people have the ability to do
so.  This BZ should have never been created in the first place.  We'll have to
deal with it here since the BZ is already created.

Comment 5 RHEL Product and Program Management 2008-06-16 23:54:57 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 8 RHEL Product and Program Management 2008-06-18 11:41:23 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being marked as a blocker for this release.  

Please resolve ASAP.

Comment 9 Jeff Moyer 2008-06-19 17:10:08 UTC
Created attachment 309865 [details]
Fix the previous patch to not loop infinitely upon finding a negative mapent.

Comment 12 errata-xmlrpc 2008-07-01 13:05:13 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0564.html


Note You need to log in before you can comment on or make changes to this bug.