Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451679 - sosreport does not capture elilo.conf
Summary: sosreport does not capture elilo.conf
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos
Version: 5.2
Hardware: ia64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Stokes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 17:18 UTC by Rick Beldin
Modified: 2008-06-16 17:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-16 17:45:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
sosreport from a HP Integrity rx2660 with RHEL5.2 (deleted)
2008-06-16 17:18 UTC, Rick Beldin
no flags Details

Description Rick Beldin 2008-06-16 17:18:16 UTC
Description of problem:  On ia64, sosreport does not capture the elilo.conf,
often a necessary piece of information in troubleshooting customer systems. 

In sosreport;s output in sosreport/sos_commands/bootloader we have two 
files: 

lilo_-q  

ls_-laR_.boot

lilo_-q is obviously incorrect on ia64: 
 /bin/sh: /sbin/lilo: No such file or directory

The ls_-laR.boot is more useful, but does not contain the *contents* of the
elilo.conf.   Seems like a 'find' command coupled with a cat could fix this. 

Version-Release number of selected component (if applicable):

sos-1.7-9.2.el5

How reproducible:

Every time

Steps to Reproduce:
1. run sosreport
2. look for elilo.conf information
3. fail to find it ;-) 
  
Actual results:


Expected results:


Additional info:

Something similar could be done for grub on other platforms.

Comment 1 Rick Beldin 2008-06-16 17:18:16 UTC
Created attachment 309518 [details]
sosreport from a HP Integrity rx2660 with RHEL5.2

Comment 2 Adam Stokes 2008-06-16 17:45:58 UTC

*** This bug has been marked as a duplicate of 337901 ***


Note You need to log in before you can comment on or make changes to this bug.