Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451678 - Changing Password Does Not Prompt the old password
Summary: Changing Password Does Not Prompt the old password
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: 389
Classification: Retired
Component: UI - Gateway/Phonebook
Version: 1.3.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 389_1.3.0
TreeView+ depends on / blocked
 
Reported: 2008-06-16 17:15 UTC by Anh Nguyen
Modified: 2015-11-13 20:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-13 20:06:08 UTC


Attachments (Terms of Use)

Description Anh Nguyen 2008-06-16 17:15:03 UTC
Description of problem:

Old password is not prompted for when changing to a new password
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. click <advance search>
2. click a person, and <edit person>
3. click <change passwd>
  
Actual results:

Enter new password 2 times
Expected results:
Prompt for old password

Additional info:

Comment 1 Rich Megginson 2008-06-16 17:23:24 UTC
Are you able to change the password without authenticating?  You should have
already authenticated in order to change the password.

Comment 2 Anh Nguyen 2008-06-23 21:24:18 UTC
(In reply to comment #1)
> Are you able to change the password without authenticating?  
No.
You should have
> already authenticated in order to change the password.
Are you suggesting this is notABug? 
Anh,


Comment 3 Rich Megginson 2008-06-23 21:30:25 UTC
If you are not able to change the password unless you authenticate, then this is
not a bug.  I suppose it could be an enhancement request to make it work like
other new password screens in other programs - prompt for old password then new
password twice.  So yes, this is either notABug or an enhancement request - in
other words, not a regression.

Comment 5 Martin Kosek 2012-01-04 13:44:26 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/119


Note You need to log in before you can comment on or make changes to this bug.