Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451648 - Impossible to reach local network when proxy is set
Summary: Impossible to reach local network when proxy is set
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 13:30 UTC by Luca Foppiano
Modified: 2018-04-11 09:07 UTC (History)
3 users (show)

Fixed In Version: firefox-3.0-1.fc9.x86_64
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-18 15:59:06 UTC


Attachments (Terms of Use)
network proxy preferences (deleted)
2008-06-17 11:43 UTC, Luca Foppiano
no flags Details
network proxy preferences (deleted)
2008-06-17 11:44 UTC, Luca Foppiano
no flags Details
network proxy preferences (deleted)
2008-06-17 11:44 UTC, Luca Foppiano
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 226823 None None None Never

Description Luca Foppiano 2008-06-16 13:30:27 UTC
Description of problem:
In GNOME, when I set a proxy and try to surf to my local address (127.0.0.1 or
localhost) it doesn't work ( I have a local application which is listening on
that address). It work on epiphany instead.

Version-Release number of selected component (if applicable):
3.0-0.60.beta5.fc9

How reproducible:
Simply set new proxy using GNOME network proxy preferences and try to connect to
a local address (you should have a local application listening).

Steps to Reproduce:
1. set proxy using gnome
2. connect to a local address:port
  
Actual results:
Firefox says "connection refused", using epiphany it works.

Expected results:
Firefox connect to local address.

Comment 1 Matěj Cepl 2008-06-16 16:06:35 UTC
Do you have in Edit/Preferences/Advanced/Network/Settings set "Use System Settings"?
What is the output of this command in xterm?

env |grep proxy

Comment 2 Luca Foppiano 2008-06-17 07:23:17 UTC
Yes. 

Remote websites works...maybe is a problem about proxy ignore host list.

[lfoppiano@sboing ~]$ env | grep proxy
[lfoppiano@sboing ~]$ 

Comment 3 Matěj Cepl 2008-06-17 09:13:13 UTC
Set your proxy correctly in gnome-network-preferences.

Comment 4 Luca Foppiano 2008-06-17 09:24:40 UTC
Proxy is correctly setted in gnome-network-preferences. 

Comment 6 Luca Foppiano 2008-06-17 11:43:56 UTC
Created attachment 309596 [details]
network proxy preferences

Comment 7 Luca Foppiano 2008-06-17 11:44:19 UTC
Created attachment 309597 [details]
network proxy preferences

Comment 8 Luca Foppiano 2008-06-17 11:44:56 UTC
Created attachment 309598 [details]
network proxy preferences

Comment 9 Luca Foppiano 2008-06-17 11:46:48 UTC
I guess my proxy preferences are corrected, in the host ignore list I have also
another field, and I can't reach to that hosts...(that hosts are locals)

With epiphany all works without problems.

Comment 11 Luca Foppiano 2008-06-18 06:56:03 UTC
ok, today when I launch env | grep proxy i got the correct strings: 

[lfoppiano@sboing ~]$ env | grep proxy
http_proxy=http://******:*********@proxy:80/
no_proxy=localhost,127.0.0.0/8,*.domain
[lfoppiano@sboing ~]$ 

I didn't do anything respect last my message... Anyone have the same problem?

Comment 12 Luca Foppiano 2008-06-18 15:59:06 UTC
I update my firefox to firefox-3.0-1.fc9.x86_64 and this bug seems to be fixed.

Luca




Note You need to log in before you can comment on or make changes to this bug.