Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451645 - Strange fonts on Lenovo T60 with radeon_tp driver
Summary: Strange fonts on Lenovo T60 with radeon_tp driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Dave Airlie
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 447321
TreeView+ depends on / blocked
 
Reported: 2008-06-16 13:04 UTC by Alan Matsuoka
Modified: 2018-10-20 02:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:39:14 UTC


Attachments (Terms of Use)
sosreport (deleted)
2008-06-16 13:04 UTC, Alan Matsuoka
no flags Details
Xorg.0.log-messy-fonts (deleted)
2008-06-16 13:05 UTC, Alan Matsuoka
no flags Details
correct.bz2 (deleted)
2008-06-16 13:05 UTC, Alan Matsuoka
no flags Details
defect.bz2 (deleted)
2008-06-16 13:06 UTC, Alan Matsuoka
no flags Details
xorg.conf (deleted)
2008-06-16 13:07 UTC, Alan Matsuoka
no flags Details
This is how it is supposed to look like (deleted)
2008-06-16 14:29 UTC, Matěj Cepl
no flags Details
This is how it looks like (deleted)
2008-06-16 14:33 UTC, Matěj Cepl
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:0166 normal SHIPPED_LIVE xorg-x11-drv-ati enhancement and bug fix update 2009-01-20 16:05:28 UTC

Description Alan Matsuoka 2008-06-16 13:04:06 UTC
Description of problem:
If I configure X11 to use the radeon_tp driver and switch back to a text
console, the fonts are ugly. This only happens after I started X (eg. no
problems in runlevel 3).

Using vesa driver doesn't corrupt the fonts.

How reproducible:
always after starting X

Steps to Reproduce:
- configure X11 to use radeon_tp driver
- start X
- switch back to text console

Actual results:
Fonts look strange

Expected results:
Fonts should be readable

Additional info:
Since this is difficult to explain, I attached two "screenshots". One before I
started X and the second after starting X.

Exiting from X doesn't fix the font issue.

Changing X configuration to another driver (eg. vesa) fixes the font issue! But
only till I switch back to radeon_tp.

radeon_tp must be used on this kind of hardware because the old driver (radeon)
doesn't support this chip.

Comment 1 Alan Matsuoka 2008-06-16 13:04:07 UTC
Created attachment 309482 [details]
sosreport

Comment 2 Alan Matsuoka 2008-06-16 13:05:24 UTC
Created attachment 309483 [details]
Xorg.0.log-messy-fonts

Comment 3 Alan Matsuoka 2008-06-16 13:05:57 UTC
Created attachment 309484 [details]
correct.bz2

Comment 4 Alan Matsuoka 2008-06-16 13:06:45 UTC
Created attachment 309486 [details]
defect.bz2

Comment 5 Alan Matsuoka 2008-06-16 13:07:53 UTC
Created attachment 309487 [details]
xorg.conf

Comment 6 Matěj Cepl 2008-06-16 14:29:47 UTC
Created attachment 309505 [details]
This is how it is supposed to look like

Comment 7 Matěj Cepl 2008-06-16 14:33:06 UTC
Created attachment 309506 [details]
This is how it looks like

Comment 10 Dave Airlie 2008-09-12 03:48:06 UTC
MODIFIED

built

xorg-x11-drv-ati-6.6.3-3.15.el5

tested on my thinkpad no more bad fonts on vt switch.

Comment 14 Cameron Meadors 2008-12-10 16:57:59 UTC
tested on many radeon cards with the r500 driver (replaces radeon_tp in 5.3).  No messy fonts to be seen.

Comment 17 errata-xmlrpc 2009-01-20 21:39:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0166.html


Note You need to log in before you can comment on or make changes to this bug.