Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451640 - The demo_log table and demo entitlement related code should go away from Satellite.
Summary: The demo_log table and demo entitlement related code should go away from Sate...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 510
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 12:38 UTC by Jan Pazdziora
Modified: 2010-09-09 20:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-09 20:33:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Pazdziora 2008-06-16 12:38:26 UTC
Description of problem:

I've tried to remove the demo_log table as Cliff suggested that it is not needed
by Satellite. However, subsequent generation of the universe.satellite.sql using

   make -f ../build/Makefile SCHEMA=satellite schema-clean schema-release

(in Spacewalk's git checkout) said that demo_log is needed by rhnDemoOrgs. When
investigating further, I found out that rhnDemoOrgs is used by rhnPaidOrgs,
which is used by package rhn_bel, which is used (at least) by
backend/server/rhnServer/server_lib.py in its throttle function / method; also,
rhnPaidOrgs is used by autoupdate_servers_for_errata which seems to be used by
web/modules/rhn/RHN/Task/ErrataQueue.pm in its schedule_autoupdates function /
method.

We might want to remove demo_log and other stuff which depends on it but I did
not want to destabilize Spacewalk one day before going public.

Version-Release number of selected component (if applicable):

Satellite 5.1.0.

How reproducible:

Deterministic.

Steps to Reproduce:
1. sqlplus rhnsat/rhnsat@rhnsat
2. SQL> desc demo_log
  
Actual results:

SQL> desc demo_log
 Name                                      Null?    Type
 ----------------------------------------- -------- ----------------------------
 ORG_ID                                             NUMBER
 SERVER_ID                                          NUMBER

SQL> 

Expected results:

SQL> desc demo_log
ERROR:
ORA-04043: object demo_log does not exist

and the rest of the Satellite continues to work.

Additional info:

Comment 4 Jan Pazdziora 2010-07-14 06:52:47 UTC
Taking.

Comment 5 Jan Pazdziora 2010-09-09 20:33:57 UTC
The cleanup has been done by Partha in Spacewalk master in commit 10c8a7dbca8a825639979f5dcb701472dd6b1d55.


Note You need to log in before you can comment on or make changes to this bug.