Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451630 - f951: internal compiler error: in gfc_assign_data_value_range, at fortran/data.c:562
Summary: f951: internal compiler error: in gfc_assign_data_value_range, at fortran/dat...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 9
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 10:44 UTC by nvwarr
Modified: 2008-06-23 08:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 08:53:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 36604 None None None Never

Description nvwarr 2008-06-16 10:44:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
Assigning data to an array twice causes an internal compiler error

Version-Release number of selected component (if applicable):
gcc-gfortran-4.3.0-8.i386 

How reproducible:
Always


Steps to Reproduce:
1.Create a program with two data lines filling an array. e.g.:
      program test
      real value(2)
      data value/2*0.0/
      data value/2*0.0/
      end
2. Compile it with gfortran -c filename

Actual Results:
cat test.f 
      program test
      real value(2)
      data value/2*0.0/
      data value/2*0.0/
      end

gfortran -c test.f 
f951: internal compiler error: in gfc_assign_data_value_range, at fortran/data.c:562
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.


Expected Results:
It should either compile, letting the second data statement override the first, or should give a warning at the second one, or an error at the second on. As it is, it is a compiler bug, because it doesn't give any indication what the error is or where. In my case it was a > 7000 line piece of legacy code which triggered the bug, so tracking it down was not easy.

Additional info:
Removing the second data statement does not give an error.


Note You need to log in before you can comment on or make changes to this bug.