Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451618 - Broadcom wireless causing system to crash with network manager.
Summary: Broadcom wireless causing system to crash with network manager.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 8
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 08:05 UTC by Ashesh
Modified: 2008-06-25 20:46 UTC (History)
3 users (show)

Fixed In Version: kernel-2.6.25.6-27.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-25 20:46:19 UTC


Attachments (Terms of Use)
/var/log/messages (deleted)
2008-06-16 08:05 UTC, Ashesh
no flags Details

Description Ashesh 2008-06-16 08:05:31 UTC
Description of problem:
I recently happened to notice something strange about my Fedora 8 laptop
(hardware specs in my signature).
Today, while playing music using amarok/audacious, I happened to see my wireless
light cycle between activated (blue) and deactivated (red) repeatedly coupled
with a heavy upsurge in hard drive usage as seen on my system monitor. I for
once let the system run, keeping the playback continued, and the same happened
after some time again. I decided to deactivate my wireless using the external
switch but as soon as I did, the system froze and I had to hit the switch.


Version-Release number of selected component (if applicable):
0.7.0

How reproducible:
Always

Steps to Reproduce:
1. Enable wireless from network manager
2. Start audio playback using amarok, etc.
3. Wireless enabled/disabled light cycles repeatedly and quickly. If wireless is
disabled using the switch at this instant, the system crashes immediately.
  
Actual results:
System freezes.

Expected results:
System should run smoothly and network manager should know that the hardware
switch for the wireless has been thrown to off.

Additional info:

Comment 1 Ashesh 2008-06-16 08:05:31 UTC
Created attachment 309469 [details]
/var/log/messages

Comment 2 Ashesh 2008-06-16 16:40:11 UTC
Hardware:
Compaq Presario V3424 AU
1.5 GB RAM
AMD Turion 2.20 Ghz @ 64
120 GB SATA HDD
Nvidia GeForce Go 6150
Broadcom w/l 43xx

Comment 3 Ashesh 2008-06-23 03:36:29 UTC
Does anyone need more information about the problem or my hardware?

Comment 4 Dhaval Giani 2008-06-23 13:18:44 UTC
This does not seem to be a NetworkManager issue. It seems to be more like a
wireless driver issue. Adding wireless maintainer to the cc.

Can you do a rpm -qv kernel as well?

Comment 5 Dhaval Giani 2008-06-23 13:19:30 UTC
BTW, have you tried updating your firmware as suggested by the logs?

Comment 6 John W. Linville 2008-06-23 19:35:45 UTC
I think there is a related fix in the latest F8 kernels...could you try one from
Koji?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=52605

Does this work better for you?

Comment 7 Ashesh 2008-06-25 20:08:16 UTC
Thank you all, I updated the drivers and it all seems to be fine now. Problem
solved.


Note You need to log in before you can comment on or make changes to this bug.