Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451617 - rhn_register TUI looks like it can be used for user registration
Summary: rhn_register TUI looks like it can be used for user registration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.7
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: John Matthews
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-16 08:04 UTC by Jan Hutař
Modified: 2008-07-24 20:06 UTC (History)
1 user (show)

Fixed In Version: RHBA-2008-0771
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 20:06:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0771 normal SHIPPED_LIVE up2date bug fix update 2008-07-23 17:20:34 UTC

Description Jan Hutař 2008-06-16 08:04:41 UTC
Description of problem:
While registering new users of RHN Hosted through rhn_register were disabled, 
rhn_register still says/looks like as it could be used for this.


Version-Release number of selected component (if applicable):
up2date-4.7.1-6.el4


How reproducible:
always


Steps to Reproduce:
1. Go through the rhn_register wizard


Actual results:
 * 2nd screen "Register with Red Hat Network":
   - There is "a. This registration program can take care of that for you"
     which is not true
   - There is "b. You can also register an account by going to
     https://rhn.redhat.com/newlogin.pxt" - link here is incorrect, it works
     only without ".pxt"
 * 4th screen "Step 2: Register a User Account":
   - Displays field "(Password) Again, for verification:", what is not
     required if you do not need to create a user
   - Asks user to provide email to "E-mail address:" what is not
     required as well


Expected results:
rhn_register should clearly state where to register and it should not ask for 
unnecessarily information (like password again or email)


Additional info:
This was discovered while testing bug 430153: remove account creation 
capability from rhn_register TUI
This is similar to bug 451194: rhn_register GUI - incorrect description

Comment 1 John Matthews 2008-06-16 21:47:06 UTC
1) Updated the "welcome message" so it no longer mentions creating a new user
from this tool.  
2) Updated tui screen to remove the no longer needed info for creating a new user.
3) Added the RHEL5 client-tools code in for determining Sat/Hosted, and printed
out a message about where to go for a forgotten password based on server type.


Sample Welcome Message:
Joining is easy-- just follow this three step process: 
Step 1: Review the Red Hat privacy policy     
Step 2: Register a user account with Red Hat.                                  
                                                   You can register an account
by going to                                                                    
              https://rhn.redhat.com/rhn/sales/LoginInfo.do 
Step 3: Register a system profile on Red Hat Network  



Sending        up2date/rhnreg.py
Adding         up2date/rhnreg_constants.py
Sending        up2date/tui.py
Transmitting file data ...
Committed revision 174070.


Comment 8 errata-xmlrpc 2008-07-24 20:06:18 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0771.html


Note You need to log in before you can comment on or make changes to this bug.