Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451576 - init[1]: segfault at 00000006 eip 00000006 esp bf87a7e8 error 4
Summary: init[1]: segfault at 00000006 eip 00000006 esp bf87a7e8 error 4
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: 8
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2008-06-16 00:09 UTC by Mrs Bonus
Modified: 2009-01-09 06:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2009-01-09 06:36:15 UTC

Attachments (Terms of Use)

Description Mrs Bonus 2008-06-16 00:09:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20071127 Firefox/

Description of problem:
I was running FC6 and yum upgraded to F8. The latest FC6 kernel version worked fine. Now that I am on F8 I can not run an F8 kernel since they always fail to boot. I am still running the latest FC6 kernel (everything else is F8). Every new F8 kernel I install has the same problem. I've extracted the initrd files and have tried a few things. If I do clean F8 installs it works every time (as you would expect) so I have some legacy problem coming from my FC6 upgrade. I have tried PAE and non-PAE kernels with the same result.

My FC6 upgrade was direct to F8 but I have tried FC6 -> F7 -> F8 as well with no luck.

The screenshot ( shows the error.
"init[1]: segfault at 00000006 eip 00000006 esp bf87a7e8 error 4"

I have now created a cut down F8 virtual machine under Vmware and copied the faulty initrd file to it. The fault is now reproducible within the VM.

I did find that if I downgraded nash and mkinitrd to an FC6 version and then installed F8 kernels that they would boot and/or get a lot further in the boot process. But I have no idea why mkinitrd and nash from F8 create an initrd for me that is not bootable. Screenshot of this new error is at I suspect that this would never work any way due to dependencies but it does appear to show that changing mkinitrd fixes the initial fault.

I have posted the faulty initrd file at

This does appear to be similar to the following bugs:
336161: I have the bug in the version that was released as the fix for this bug.
411691: This bug stops the boot process in the same place, except that I've already fixed the problem I had with the ld libraries.
440091: Sounds very close but I've already fixed up the mismatching of and

I would love to get my hands on a later release of mkinitrd for F8. I note that mkinitrd for F9 is has much later versions available - where are the ones for F8?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Try booting the faulty initrd described above

Actual Results:

Expected Results:

Additional info:

Comment 1 Bug Zapper 2008-11-26 10:52:27 UTC
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here:

Comment 2 Bug Zapper 2009-01-09 06:36:15 UTC
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.