Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451570 - wings executable fails to run -- missing file
Summary: wings executable fails to run -- missing file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wings
Version: 8
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 445595 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 22:47 UTC by Ed Hill
Modified: 2008-07-26 06:04 UTC (History)
1 user (show)

Fixed In Version: 0.99.02-2.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 02:10:00 UTC


Attachments (Terms of Use)

Description Ed Hill 2008-06-15 22:47:13 UTC
Description of problem:
The "wings" executable fails due to a missing file:

  $ sudo yum install wings wings-docs wings-povray
  $ wings
  erlexec: Error 2 executing '/usr/lib64/wings/bin/beam.smp'.
  $ ls /usr/lib64/wings/bin/beam.smp
  ls: cannot access /usr/lib64/wings/bin/beam.smp: No such file or directory


Version-Release number of selected component (if applicable):
wings-0.99.02-1.fc8.x86_64

How reproducible:
100%

Comment 1 Ed Hill 2008-06-16 00:19:07 UTC
I can get the "wings" command to run if I add the soft-link:

  ( cd /usr/lib64/wings/bin ; ln -s beam beam.smp )

but perhaps there is a better fix?  Also, I'm new to wings so 
please let me know if I'm doing something wrong.

Thanks!

Comment 2 Gérard Milmeister 2008-06-17 16:27:55 UTC
I rebuild wings with the flag -smpdisable in the script. Please check out from
F9 updates testing and report back.

Comment 3 Fedora Update System 2008-06-17 17:07:52 UTC
wings-0.99.02-2.fc9 has been submitted as an update for Fedora 9

Comment 4 Fedora Update System 2008-06-20 19:11:59 UTC
wings-0.99.02-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wings'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5512

Comment 5 Ed Hill 2008-06-21 19:43:09 UTC
Could you please do a build for F8 in addition to F9?  Thank you!

Comment 6 Fedora Update System 2008-06-22 10:42:09 UTC
wings-0.99.02-2.fc8 has been submitted as an update for Fedora 8

Comment 7 Gérard Milmeister 2008-07-06 11:29:46 UTC
*** Bug 445595 has been marked as a duplicate of this bug. ***

Comment 8 Frank Murphy 2008-07-06 12:10:15 UTC
I'm having trouble logging in to the accounts system,
http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5512
so I'll report here.

It launches, but if I close it (click the x) as user if cause a re-login to the
box. Doesn't happes as root.



Comment 9 Fedora Update System 2008-07-24 02:09:58 UTC
wings-0.99.02-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2008-07-24 02:11:46 UTC
wings-0.99.02-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2008-07-26 06:04:25 UTC
wings-0.99.02-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.