Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451563 - Kernel 2.6.26-0.67 fails to boot with encrypted root partition
Summary: Kernel 2.6.26-0.67 fails to boot with encrypted root partition
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 21:05 UTC by Mike C
Modified: 2008-07-14 11:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 11:55:35 UTC


Attachments (Terms of Use)
/var/log/messages including last login with 2.6.26-0.67 ok (deleted)
2008-06-15 21:16 UTC, Mike C
no flags Details

Description Mike C 2008-06-15 21:05:02 UTC
Description of problem:
Booting the previous kernel works fine, but booting new kernel fails to request
luks passphrase to decrypt luks encrypted root partition

Version-Release number of selected component (if applicable):
2.6.26-0.67.rc6.git1.fc10.i686

How reproducible:Every time


Steps to Reproduce:
1. Boot
2. At console line: "padlock: VIA Padlock Has Engine not detected." fails
3. Further console lines below.
  
Actual results:
Next console lines are:
Loading /lib/kbd/keymaps/i386/querty/uk.map
Command failed: Error opening key file: No such file or directory
mount: error mounting /dev/root on /sysroot as ext3: No such file or directory
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Mount failed for selinuxfs on /selinux: No such file or directory
switchroot: mount failed: No such file or directory

Then it hangs.
Expected results:

Boot should continue to next phase and ask for luks passphrase
Additional info:

Comment 1 Mike C 2008-06-15 21:07:57 UTC
2.6.26-0.56.rc5.git2.fc10.i686 boots fine... for this kernel after the console line:
Loading /lib/kbd/keymaps/i386/querty/uk.map
the next line is:
Enter LUKS passphrase for /dev/sda8:

I will add /var/log/messages shortly.

Comment 2 Mike C 2008-06-15 21:16:24 UTC
Created attachment 309411 [details]
/var/log/messages including last login with 2.6.26-0.67 ok

Comment 3 Mike C 2008-06-16 21:03:30 UTC
In comment #2 the log shows boot with 2.6.26-0.56.rc5.git2.fc10 not with
2.6.26-0.67 - my apology. Since the encrypted disc is not mounted there is no
log for the boot attempt with that kernel of course.

Comment 4 Kyle McMartin 2008-07-08 17:45:33 UTC
It looks as though the initrd wasn't created properly. Can you try updating the
kernel and mkinitrd and trying again?

The VIA padlock message is harmless, since you don't have a VIA cpu (from your
/var/log/messages file, it appears to be a Pentium 4?)

regards, Kyle

Comment 5 Mike C 2008-07-14 11:54:21 UTC
Thanks Kyle - yes you were right - new kernel worked fine.


Note You need to log in before you can comment on or make changes to this bug.