Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451559 - KDEInit could not launch /usr/bin/ktorrent
Summary: KDEInit could not launch /usr/bin/ktorrent
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ktorrent
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Roland Wolters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 457282 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 20:14 UTC by Evert
Modified: 2008-10-25 17:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-24 23:52:02 UTC


Attachments (Terms of Use)
error (deleted)
2008-06-16 02:52 UTC, Evert
no flags Details


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 157853 None None None Never

Description Evert 2008-06-15 20:14:58 UTC
I have installed a fresh installation of Fedora 9, with all the required updates.

However, when i run ktorrent, i got an error saying:
KDEInit could not launch /usr/bin/ktorrent, in a window with the title: Sorry,,
plasma workspace

ktorrent starts normally when i close this plasma window

Comment 1 Rex Dieter 2008-06-15 20:32:31 UTC
wow, never seen or heard of that before.  By "when I run ktorrent", you mean via
the kickoff menu?

Comment 2 Evert 2008-06-16 02:52:06 UTC
Created attachment 309438 [details]
error

Comment 3 Evert 2008-06-16 02:53:29 UTC
both,, via kickoff and desktop shortcut

Comment 4 Roland Wolters 2008-06-17 12:48:48 UTC
Please try if the error also occurs when you run ktorrent from a terminal.
(Open "konsole", type
ktorrent
and press enter)
If yes, then please copy the output in console and attach it to this bug 
report. Also, please check your ~/.xsession-errors and post the content 
created right before and after you tried to run ktorrent. In case you don't 
know how to monitor ~/.xsession-errors :
Just before you try to start ktorrent, open a terminal (like konsole), and 
type 
tail -f ~/.xsession-errors
. That will monitor the file and will show all new content.

Besides, does the application actually start up? And what is about other 
applications? Are they working fine?

Possible references:
https://bugs.launchpad.net/ubuntu/+source/kde4libs/+bug/184337
http://bugs.kde.org/show_bug.cgi?id=75492

Comment 5 Evert 2008-06-17 13:57:54 UTC
Hello

running ktorrent from a terminal does not create the error.
When i close then,, i get: 

localhost ~]$ ktorrent
[evert@localhost ~]$ QCoreApplication::postEvent: Receiver is not a valid QObject
QCoreApplication::postEvent: Receiver is not a valid QObject


localhost ~]$ tail -f ~/.xsession-errors
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  20
  Minor opcode:  0
  Resource id:  0x3805829
Enchant dict for "en_US" 0x92eb9c8
QObject::connect: Cannot connect KNotification::action2Activated() to
(null)::discard()
QObject::connect: Cannot connect (null)::done(Kopete::MessageEvent*) to
KNotification::close()
ktorrent is already running !
QCoreApplication::postEvent: Receiver is not a valid QObject
QCoreApplication::postEvent: Receiver is not a valid QObject
QPainter::end: Painter ended with 3 saved states
QPainter::end: Painter ended with 2 saved states
QPainter::end: Painter ended with 2 saved states
QPainter::end: Painter ended with 2 saved states
QPainter::end: Painter ended with 3 saved states
QPainter::end: Painter ended with 3 saved states
QPainter::end: Painter ended with 3 saved states
QPainter::end: Painter ended with 3 saved states
QPainter::end: Painter ended with 2 saved states
QPainter::end: Painter ended with 2 saved states
ktorrent is already running !
QCoreApplication::postEvent: Receiver is not a valid QObject
QCoreApplication::postEvent: Receiver is not a valid QObject

Yes,, the application does start and works fine
I experiencing some other small problems with other apps, but these
problems/errors are not related to this problem i think. eg: amsn starts, but
when i want to chat the app will go into a sort off loping between the main amsn
window and the contact's chat windows. ctrl+alt+backspace will couse me to log
out, and after login amsn is closed. Now running kopette, pidgin is a good app also.

Yes,, i noticed bug 184337

Thanks


Comment 6 Evert 2008-06-17 14:00:12 UTC
remark: pls ignore the line: ktorrent is already running !
i started ktorrent tice by mistake

Comment 7 Roland Wolters 2008-06-18 09:38:19 UTC
Was the tail output created when there was the Plasma error? If not, can you 
create a tail when you see the actual bug?

Comment 8 Rex Dieter 2008-07-27 23:23:19 UTC
just tried ktorrent-3.1, can confirm issue gone (for me).

Comment 9 Steven M. Parrish 2008-07-28 20:42:30 UTC
Is this still an issue or has this been resolved to your satisfaction.

Comment 10 Rex Dieter 2008-07-28 20:49:41 UTC
ktorrent-3.1 isn't available for F-9 (yet).

Comment 11 Roland Wolters 2008-07-28 23:31:45 UTC
Ktorrent 3.1 requires KDE 4.1, so it will not be available for F9.

Comment 12 Rex Dieter 2008-07-28 23:52:53 UTC
*ahem*,
http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6743

:)

Comment 13 Rex Dieter 2008-07-30 17:12:49 UTC
*** Bug 457282 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2008-08-05 14:34:43 UTC
ktorrent-3.1-5.fc9 has been submitted as an update for Fedora 9

Comment 15 Fedora Update System 2008-08-07 23:54:38 UTC
ktorrent-3.1-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ktorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7070

Comment 16 Fedora Update System 2008-08-12 18:17:47 UTC
ktorrent-3.1.2-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ktorrent'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7070

Comment 17 l ciani 2008-08-21 09:14:33 UTC
Updated to ktorrent-3.1.2-1.fc9.

I still have an issue when I run it from krunner - I press Alt+F2 and I key in "ktorrent".

Krunner gives me 2 choices: "execute ktorrent" or "KTorrent BitTorrent client".

If I click on "KTorrent BitTorrent client" I get a pop-up window saying "KDEInit could not start /usr/bin/ktorrent". Ktorrent starts and runs smoothly.

If I click on "execute ktorrent" I don't get any pop-up windows. Ktorrent starts and runs fine.

Also, when I execute "ktorrent" from konsole I get this message: "ktorrent(20516)/kdeui (K*Gesture*) KAction::setGlobalShortcut: Attempt to set global shortcut for action without objectName(). Read the setGlobalShortcut() documentation."

If I run ktorrent from the KDE Menu I don't get any error message at all.

In any case ktorrent starts and runs smoothly.

Comment 18 Rex Dieter 2008-08-21 13:27:23 UTC
lciani, 
rpm -q kdelibs
please

Comment 19 l ciani 2008-08-24 18:44:20 UTC
Rex here's my rpm -q kdelibs

kdelibs-4.1.0-4.fc9.i386

Regards.

Comment 20 Fedora Update System 2008-09-10 07:10:24 UTC
ktorrent-3.1.2-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Rex Dieter 2008-09-10 12:42:07 UTC
confirmed comment #17, I just saw this yesterday.  bleh.

Comment 22 Rex Dieter 2008-09-10 12:45:57 UTC
Seems related to 
http://bugs.kde.org/show_bug.cgi?id=157853

someone there commented:
"removing: "X-DBUS-StartupType=Unique" from desktop file solves this problem "
hmm...

Comment 23 Rex Dieter 2008-10-14 20:07:38 UTC
Or better, from dfaure's similar fix for kate:
http://bugs.kde.org/show_bug.cgi?id=157853#c16

Comment 24 Fedora Update System 2008-10-14 20:43:08 UTC
ktorrent-3.1.3-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/ktorrent-3.1.3-4.fc9

Comment 25 Fedora Update System 2008-10-23 17:44:53 UTC
ktorrent-3.1.4-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/ktorrent-3.1.4-1.fc9

Comment 26 Fedora Update System 2008-10-24 23:51:56 UTC
ktorrent-3.1.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 l ciani 2008-10-25 17:38:57 UTC
ktorrent-3.1.4-1.fc9 on kdebase-4.1.2-5.fc9 I am happy to report that the annoying pop-up window saying "KDEInit could not start /usr/bin/ktorrent" is gone.

However If I run ktorrent from konsole I still get the following message: "ktorrent(31548)/kdeui (K*Gesture*) KAction::setGlobalShortcut: Attempt to set global shortcut for action without objectName(). Read the setGlobalShortcut() documentation."

Thanks a million for ktorrent!!!


Note You need to log in before you can comment on or make changes to this bug.