Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451549 - firefox hangs when accessing some pages
Summary: firefox hangs when accessing some pages
Keywords:
Status: CLOSED DUPLICATE of bug 447444
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 16:31 UTC by Horst H. von Brand
Modified: 2018-04-11 10:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-16 05:37:15 UTC


Attachments (Terms of Use)
Output as directed (deleted)
2008-06-16 01:22 UTC, Horst H. von Brand
no flags Details
Direct output from firefox, outside of gdb (deleted)
2008-06-16 01:27 UTC, Horst H. von Brand
no flags Details
gunzipped attachment 309428 (deleted)
2008-06-16 05:36 UTC, Matěj Cepl
no flags Details

Description Horst H. von Brand 2008-06-15 16:31:42 UTC
Description of problem:
Accessing for example pages created with trac or the comment editor for
<http://www.lwn.net> or <http://groklaw.net>, or the list administration pages
created by Mailman makes firefox hang completely. This bugzilla is also a good
way to hang it.

Version-Release number of selected component (if applicable):
firefox-3.0-0.65.cvs20080416.fc10.i386

How reproducible:
Very often

Steps to Reproduce:
1. Go to http://bugzilla.redhat.com, "My Front Page"
2. Select some bug from there
3.
  
Actual results:
Half the page for the bug shows up, firefox hangs. Minimizing and restoring the
firefox window shows no contents, just the border. Clicking on 'x' (close
window) shows an error message saying it is hung, telling it to "Wait" goes
nowhere, need to "Kill now".

Expected results:


Additional info:

Comment 1 Matěj Cepl 2008-06-15 18:59:35 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of
gdb debugger. Then use command run and do whatever you did to make firefox
freeze. When it happens, press Ctrl-C in gdb window to get prompt back and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text
editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Horst H. von Brand 2008-06-16 01:22:45 UTC
Created attachment 309428 [details]
Output as directed

As directed, went:
firefox -g http://bugzilla.redhat.com, --> "My Front Page" --> This bug; DDD
opens. Hang; wait a while, no output, ctrl-C. Output attached (neither galeon
nor epiphany allowed me to enter a file; had to use links)

Comment 3 Horst H. von Brand 2008-06-16 01:23:54 UTC
Sorry, had to gzip the above output as the original file wouldn't go through.

Comment 4 Horst H. von Brand 2008-06-16 01:27:33 UTC
Created attachment 309429 [details]
Direct output from firefox, outside of gdb

Comment 5 Matěj Cepl 2008-06-16 05:36:11 UTC
Created attachment 309445 [details]
gunzipped attachment 309428 [details]

Err, I see what's the problem.

Comment 6 Matěj Cepl 2008-06-16 05:37:15 UTC

*** This bug has been marked as a duplicate of 447444 ***


Note You need to log in before you can comment on or make changes to this bug.