Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451546 - anaconda unhandled exception for Yum Repo error
Summary: anaconda unhandled exception for Yum Repo error
Keywords:
Status: CLOSED DUPLICATE of bug 451068
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 14:10 UTC by G.Wolfe Woodbury
Modified: 2008-06-16 22:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-16 13:13:44 UTC


Attachments (Terms of Use)
dmesg dump from latest failure (deleted)
2008-06-16 13:06 UTC, G.Wolfe Woodbury
no flags Details

Description G.Wolfe Woodbury 2008-06-15 14:10:57 UTC
Description of problem:
  anaconda dies without an exception when there is a yum repo error in current
rawhide (20080614).  The symptom is that everything seems to go correct until
after the depsolving and about ready to actually installing packages; then
screen goes black with a watch cursor.  VT01 shows:

  YumRepo Error: all mirror URLs are not using ftp, http[s] or file.
  E.g.
  Install exited abnormally [1/1]

I suspect that the install image repolist is malformed somewhere.


Version-Release number of selected component (if applicable):
  anaconda-11.4.1.5

How reproducible:
  consistent

Steps to Reproduce:
1. boot via vmlinuz & initrd.img from isolinux in GRUB
2. do usual install things (I opted to customize software)
3. wait for install
  
Actual results:
  black screen with watch cursor and message (above) on VT1


Expected results:
  normal install

Additional info:

  note that the repo selection box has two repositories:
    Fedora
    Fedora Rawhide

  not just rawhide.

platform: i686 testbed work1 used many times, smolt id not available at this time.

Comment 1 G.Wolfe Woodbury 2008-06-15 20:56:47 UTC
specifically removed the "Fedora Rawhide" repository and still go the error.
anaconda or yum is not recognizing a NFS mounted repository and failing.

Comment 2 Seth Vidal 2008-06-15 21:14:27 UTC
What's the baseurl you're using for this nfs-mounted repo?

Comment 3 G.Wolfe Woodbury 2008-06-15 22:02:08 UTC
I fill in the NFS screen and anaconda mounts:

wolves.private:/srv/Fedora/development/i386/os/

This is mounted as /mnt/source

There is a proper repodata directory, but no nfs:// indicator anywhere to be seen.

Comment 4 G.Wolfe Woodbury 2008-06-16 01:35:05 UTC
Leaving both repos selected, and using an http: URL for the local mirror results
in the bug happening.

Later I'll try with only the local mirror selected.


Comment 5 G.Wolfe Woodbury 2008-06-16 05:09:00 UTC
test done.  Pointing to the http version of the local mirror, all is well up to
the point of actually installing.  Then "The Error" occurs and all that is left
is a black screen, watch cursor and the cryptic error message noted in comment #1.

In repository selection, only the local mirror was selected ("Fedora")

http://10.11.12.1/archive/fedora/development/i386/os/
(yes that is correct, stage2 fetches just fine, and headers are fetched just fine)

I can't think of what to try next.

Comment 6 Chris Lumens 2008-06-16 12:44:25 UTC
Are there any obvious error messages on tty3 or tty4?  It sounds like everything
is working as it should up to the point where you get stuck.  The YumRepo error
message looks suspicious but it hasn't stopped me from doing installations so
far, though I really do need to track it down.

Comment 7 G.Wolfe Woodbury 2008-06-16 13:05:14 UTC
No, there is nothing obvious in any of the VTs except the noted messages from VT1

There is one warning message about substituting texlive for a different package,
but that's been there for a while. (vt3 during package selection)

examining dmesg from vt2 shell reveals a kernel oops!  Looks like the do_split
error in an ext3 call from anaconda.  This has been noted on the mailing list at
least once.

I'll attach a dump of the dmesg I managed to salvage.

Comment 8 G.Wolfe Woodbury 2008-06-16 13:06:41 UTC
Created attachment 309485 [details]
dmesg dump from latest failure

Comment 9 Chris Lumens 2008-06-16 13:13:44 UTC

*** This bug has been marked as a duplicate of 451068 ***

Comment 10 Darwin H. Webb 2008-06-16 22:32:16 UTC
+1 for June 16th

Why is the selected http mirror not being used exclusively as usual?
It goes out to different ones now.

There was a py:64 error afew lines above the 
YumRepo Error: all mirror URLs are not using ftp, http[s] or file.
  E.g.
  Install exited abnormally [1/1]


As an added note: On the first attempt to install /mounts across to pv-vg on lv
of ext4 - yiles. lots pf pvcreate errors and when I restated the installer the
pv-vg on the sda2 had all sorts of sizes, ext(3.,4) and a foreign for lv's and
the sbd (pc-vg) was unused. I think it was python-2.5 errors about pvcreate stuff?

Darwin




Note You need to log in before you can comment on or make changes to this bug.