Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451545 - yum-3.2.8-2.fc8.noarch.rpm unsigned
Summary: yum-3.2.8-2.fc8.noarch.rpm unsigned
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-presto
Version: 8
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Jonathan Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 13:40 UTC by Frank Murphy
Modified: 2014-01-21 23:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-17 05:17:19 UTC


Attachments (Terms of Use)

Description Frank Murphy 2008-06-15 13:40:09 UTC
Description of problem:

Downloading Packages:
Downloading DeltaRPMs:
Rebuilding rpms from deltarpms
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 30c9ecf8


Public key for yum-3.2.8-2.fc8.noarch.rpm is not installed



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Seth Vidal 2008-06-16 18:44:34 UTC
Reassigning to presto b/c from what I can tell this is a result of presto.

feel free to bounce it back to yum if I'm wrong.

Comment 2 Jonathan Dieter 2008-06-17 03:37:03 UTC
It's most definitely not presto; the problem is that yum-3.2.8-2.fc8.noarch.rpm
was signed using the updates-testing key rather than the normal updates key.  If
the original reporter has never used the updates-testing repository, then yum
won't know to install the updates-testing key.

IMO, this isn't a yum bug either, but rather a build system bug.  The package
should never have gone into updates with the updates-testing key attached.  I'm
reassigning to buildsystem, but if that's incorrect, feel free to bounce it
where it does belong.

Comment 3 Jonathan Dieter 2008-06-17 05:17:19 UTC
Uh, okay, right.  So I was completely right...and absolutely wrong.  I was right
that it was a problem with the buildsystem...but not the Fedora buildsystem. 
The presto test repository uses reposync to get updates for F8 rather than
rsync.  I've changed this for F9+, but hadn't really gotten around to changing
it for F8.

Anyhow, yum-3.2.8-2.fc8 *did* originally come out signed with the
updates-testing key, but it was fixed within a few hours.  Unfortunately,
reposync didn't see that there was any difference, so the test repository has
just carried the old version (with the wrong key) until now.  I've fixed it and
apologize for the extra noise.

Closing as ERRATA because it's not really a bug in yum-presto, so I can't really
say which version it's fixed in.


Note You need to log in before you can comment on or make changes to this bug.